aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:44:13 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:44:13 +0000
commit3936ed402896c4e35ba9a84cc31f92feecb0a139 (patch)
tree3c2e635490d0f7f3f8b6d7d7e05feeba57474d87
parent14421bd7fbc53ced274d758fe3d6fe53ee8c7b20 (diff)
downloadupstream-3936ed402896c4e35ba9a84cc31f92feecb0a139.tar.gz
upstream-3936ed402896c4e35ba9a84cc31f92feecb0a139.tar.bz2
upstream-3936ed402896c4e35ba9a84cc31f92feecb0a139.zip
package/Makefile: Substituted deprecated -perm +mode with -perm /mode
The find(1) -perm +mode is no longer supported and has been deprecated since 2005. This could resolve #13855 ticket. Signed-off-by: Rocco Folino <lordzen87@gmail.com> SVN-Revision: 40927
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index e189e37043..1930d27cf8 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,7 +26,7 @@ ifdef CONFIG_USE_MKLIBS
define mklibs
rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
# first find all programs and add them to the mklibs list
- find $(STAGING_DIR_ROOT) -type f -perm +100 -exec \
+ find $(STAGING_DIR_ROOT) -type f -perm /100 -exec \
file -r -N -F '' {} + | \
awk ' /executable.*dynamically/ { print $$1 }' > $(TMP_DIR)/mklibs-progs
# find all loadable objects that are not regular libraries and add them to the list as well
Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
config IB
	bool "Build the OpenWrt Image Builder"
	depends !TARGET_ROOTFS_INITRAMFS
	depends !PROFILE_KCONFIG
	depends !LINUX_2_6_UML
	default y if ALL
	help
	  This is essentially a stripped-down version of the buildroot
	  with precompiled packages, kernel image and image building tools.
	  You can use it to generate custom images without compiling anything