aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-08-30 08:45:39 +0200
committerPetr Štetiar <ynezz@true.cz>2022-09-16 18:50:46 +0200
commitb531611f57342cbfa8075a38f1ade51fe56c1e9f (patch)
treeb24f92b02b08d2c22b0d800c3f08b52c57952c64
parent542447b93e4263ee717caf5881a6b3f542b2176b (diff)
downloadupstream-b531611f57342cbfa8075a38f1ade51fe56c1e9f.tar.gz
upstream-b531611f57342cbfa8075a38f1ade51fe56c1e9f.tar.bz2
upstream-b531611f57342cbfa8075a38f1ade51fe56c1e9f.zip
build: provide xxd -i with scripts/xxdi.pl
Dependency on xxd was added in commit c4dd2441e787 ("tools: add xxd (from vim)") as U-Boot requires xxd to create the default environment from an external file. Later in commit 2b94aac7a128 ("tools: xxd: use more convenient source tarball"), xxd from another source was used instead, but that source is currently unavailable, so let's fix it by using simple xxdi.pl Perl script instead. Fixes: #10555 Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit eae2fb8027cb892e42181e471ba344aa5d26bf7e)
-rw-r--r--include/prereq-build.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 70e1061680..8998e76fd0 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -202,7 +202,10 @@ $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)
$(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
-prereq: $(STAGING_DIR_HOST)/bin/mkhash
+$(STAGING_DIR_HOST)/bin/xxd: $(SCRIPT_DIR)/xxdi.pl
+ $(LN) $< $@
+
+prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \