diff options
author | Gabor Juhos <juhosg@openwrt.org> | 2009-09-08 07:25:20 +0000 |
---|---|---|
committer | Gabor Juhos <juhosg@openwrt.org> | 2009-09-08 07:25:20 +0000 |
commit | f7033929faab94a2b06a8a6a527b1bfcd9de0296 (patch) | |
tree | ca44051ca06a628fa212539bf205490eea8828d3 | |
parent | 04f8c5293d8d8475e5d2c5fe72edad2fc21d220a (diff) | |
download | upstream-f7033929faab94a2b06a8a6a527b1bfcd9de0296.tar.gz upstream-f7033929faab94a2b06a8a6a527b1bfcd9de0296.tar.bz2 upstream-f7033929faab94a2b06a8a6a527b1bfcd9de0296.zip |
add menuconfig option for enabling debugfs support in the kernel
SVN-Revision: 17540
-rw-r--r-- | Config.in | 10 | ||||
-rw-r--r-- | include/kernel-defaults.mk | 1 |
2 files changed, 11 insertions, 0 deletions
@@ -195,6 +195,7 @@ config KERNEL_KALLSYMS default n help This will give you more information in stack traces from kernel oopses + config KERNEL_PROFILING bool "Compile the kernel with profiling enabled" default n @@ -202,6 +203,15 @@ config KERNEL_PROFILING Enable the extended profiling support mechanisms used by profilers such as OProfile. +config KERNEL_DEBUG_FS + bool "Compile the kernel with Debug Filesystem enabled" + depends LINUX_2_6 + default y + help + debugfs is a virtual file system that kernel developers use to put + debugging files into. Enable this option to be able to read and + write to these files. + endmenu menuconfig DEVEL diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk index 4266157d26..cf3eb31053 100644 --- a/include/kernel-defaults.mk +++ b/include/kernel-defaults.mk @@ -97,6 +97,7 @@ define Kernel/Configure/Default $(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target echo "$(if $(CONFIG_KERNEL_PROFILING),CONFIG_PROFILING=y,# CONFIG_PROFILING is not set)" >> $(LINUX_DIR)/.config.target + echo "$(if $(CONFIG_KERNEL_DEBUG_FS),CONFIG_DEBUG_FS=y,# CONFIG_DEBUG_FS is not set)" >> $(LINUX_DIR)/.config.target echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target |