aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-09-26 17:53:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-09-26 17:53:20 +0000
commit49104b584382ccbd7e30f7d097f81fdee993099b (patch)
tree3b06231fadc4377ff691cf2308f3b3ec17c8309b /include
parentb2e35bbd7b6c12b82f7d22356b0369dc81116ec3 (diff)
downloadupstream-49104b584382ccbd7e30f7d097f81fdee993099b.tar.gz
upstream-49104b584382ccbd7e30f7d097f81fdee993099b.tar.bz2
upstream-49104b584382ccbd7e30f7d097f81fdee993099b.zip
build: unify arm target cflags
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38211 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/target.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index f9f378a8d8..8c427c0c4f 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -217,7 +217,16 @@ ifeq ($(DUMP),1)
endif
ifneq ($(findstring arm,$(ARCH)),)
CPU_TYPE ?= xscale
+ CPU_CFLAGS_arm920t = -march=armv4t -mtune=arm920t
+ CPU_CFLAGS_arm926ej-s = -march=armv5te -mtune=arm926ej-s
+ CPU_CFLAGS_arm1136j-s = -march=armv6 -mtune=arm1136j-s
+ CPU_CFLAGS_arm1176jzf-s = -march=armv6 -mtune=arm1176jzf-s
+ CPU_CFLAGS_cortex-a9 = -march=armv7-a -mtune=cortex-a9
+ CPU_CFLAGS_fa526 = -march=armv4 -mtune=fa526
+ CPU_CFLAGS_mpcore = -march=armv6k -mtune=mpcore
CPU_CFLAGS_xscale = march=armv5te -mtune=xscale
+ CPU_CFLAGS_vfp = -mfpu=vfp -mfloat-abi=softfp
+ CPU_CFLAGS_vfp3 = -mfpu=vfp3-d16 -mfloat-abi=softfp
endif
ifeq ($(ARCH),sparc)
CPU_TYPE = sparc