aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/mbedtls
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-03-30 13:18:34 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-31 16:30:30 +0200
commit2e75914bee0f366f4484a143a45ab3d74935dd94 (patch)
tree418646d20d9a3e70815c9e4bfb95f33d11fea092 /package/libs/mbedtls
parent8c2b8d862b8de10c6de303efb615d2ef2dfbbde5 (diff)
downloadupstream-2e75914bee0f366f4484a143a45ab3d74935dd94.tar.gz
upstream-2e75914bee0f366f4484a143a45ab3d74935dd94.tar.bz2
upstream-2e75914bee0f366f4484a143a45ab3d74935dd94.zip
mbedtls: update to version 2.8.0
This fixes some minor security problems. Old size: 162262 bin/packages/mips_24kc/base/libmbedtls_2.7.0-1_mips_24kc.ipk New size: 163162 bin/packages/mips_24kc/base/libmbedtls_2.8.0-1_mips_24kc.ipk Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/libs/mbedtls')
-rw-r--r--package/libs/mbedtls/Makefile4
-rw-r--r--package/libs/mbedtls/patches/200-config.patch36
2 files changed, 20 insertions, 20 deletions
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index 8f6a5be295..898880d453 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mbedtls
-PKG_VERSION:=2.7.0
+PKG_VERSION:=2.8.0
PKG_RELEASE:=1
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
PKG_SOURCE_URL:=https://tls.mbed.org/download/
-PKG_HASH:=2c6fe289b4b50bf67b4839e81b07fcf52a19f5129d0241d2aa4d49cb1ef11e4f
+PKG_HASH:=649eb27187154590edda52943a7f468e740ec08807e5bf68ff45f4e8ffd68923
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPL-2.0+
diff --git a/package/libs/mbedtls/patches/200-config.patch b/package/libs/mbedtls/patches/200-config.patch
index 3860414cde..70ef95477c 100644
--- a/package/libs/mbedtls/patches/200-config.patch
+++ b/package/libs/mbedtls/patches/200-config.patch
@@ -91,7 +91,7 @@
/**
* \def MBEDTLS_ENTROPY_NV_SEED
-@@ -1056,14 +1056,14 @@
+@@ -1057,14 +1057,14 @@
* Uncomment this macro to disable the use of CRT in RSA.
*
*/
@@ -108,7 +108,7 @@
/**
* \def MBEDTLS_SHA256_SMALLER
-@@ -1079,7 +1079,7 @@
+@@ -1080,7 +1080,7 @@
*
* Uncomment to enable the smaller implementation of SHA256.
*/
@@ -117,7 +117,7 @@
/**
* \def MBEDTLS_SSL_ALL_ALERT_MESSAGES
-@@ -1206,7 +1206,7 @@
+@@ -1207,7 +1207,7 @@
* configuration of this extension).
*
*/
@@ -126,7 +126,7 @@
/**
* \def MBEDTLS_SSL_SRV_SUPPORT_SSLV2_CLIENT_HELLO
-@@ -1380,8 +1380,8 @@
+@@ -1381,8 +1381,8 @@
* callbacks are provided by MBEDTLS_SSL_TICKET_C.
*
* Comment this macro to disable support for SSL session tickets
@@ -136,7 +136,7 @@
/**
* \def MBEDTLS_SSL_EXPORT_KEYS
-@@ -1411,7 +1411,7 @@
+@@ -1412,7 +1412,7 @@
*
* Comment this macro to disable support for truncated HMAC in SSL
*/
@@ -144,8 +144,8 @@
+//#define MBEDTLS_SSL_TRUNCATED_HMAC
/**
- * \def MBEDTLS_THREADING_ALT
-@@ -1445,8 +1445,8 @@
+ * \def MBEDTLS_SSL_TRUNCATED_HMAC_COMPAT
+@@ -1470,8 +1470,8 @@
* Requires: MBEDTLS_VERSION_C
*
* Comment this to disable run-time checking and save ROM space
@@ -155,7 +155,7 @@
/**
* \def MBEDTLS_X509_ALLOW_EXTENSIONS_NON_V3
-@@ -1773,7 +1773,7 @@
+@@ -1801,7 +1801,7 @@
* MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256
* MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256
*/
@@ -164,7 +164,7 @@
/**
* \def MBEDTLS_CCM_C
-@@ -1787,7 +1787,7 @@
+@@ -1815,7 +1815,7 @@
* This module enables the AES-CCM ciphersuites, if other requisites are
* enabled as well.
*/
@@ -173,7 +173,7 @@
/**
* \def MBEDTLS_CERTS_C
-@@ -1799,7 +1799,7 @@
+@@ -1827,7 +1827,7 @@
*
* This module is used for testing (ssl_client/server).
*/
@@ -182,7 +182,7 @@
/**
* \def MBEDTLS_CIPHER_C
-@@ -1852,7 +1852,7 @@
+@@ -1880,7 +1880,7 @@
*
* This module provides debugging functions.
*/
@@ -191,7 +191,7 @@
/**
* \def MBEDTLS_DES_C
-@@ -1881,7 +1881,7 @@
+@@ -1909,7 +1909,7 @@
* \warning DES is considered a weak cipher and its use constitutes a
* security risk. We recommend considering stronger ciphers instead.
*/
@@ -200,7 +200,7 @@
/**
* \def MBEDTLS_DHM_C
-@@ -2042,8 +2042,8 @@
+@@ -2070,8 +2070,8 @@
* Requires: MBEDTLS_MD_C
*
* Uncomment to enable the HMAC_DRBG random number geerator.
@@ -210,7 +210,7 @@
/**
* \def MBEDTLS_MD_C
-@@ -2337,7 +2337,7 @@
+@@ -2365,7 +2365,7 @@
* Caller: library/md.c
*
*/
@@ -219,7 +219,7 @@
/**
* \def MBEDTLS_RSA_C
-@@ -2421,8 +2421,8 @@
+@@ -2449,8 +2449,8 @@
* Caller:
*
* Requires: MBEDTLS_SSL_CACHE_C
@@ -229,7 +229,7 @@
/**
* \def MBEDTLS_SSL_COOKIE_C
-@@ -2443,8 +2443,8 @@
+@@ -2471,8 +2471,8 @@
* Caller:
*
* Requires: MBEDTLS_CIPHER_C
@@ -239,7 +239,7 @@
/**
* \def MBEDTLS_SSL_CLI_C
-@@ -2543,8 +2543,8 @@
+@@ -2571,8 +2571,8 @@
* Module: library/version.c
*
* This module provides run-time version information.
@@ -249,7 +249,7 @@
/**
* \def MBEDTLS_X509_USE_C
-@@ -2654,7 +2654,7 @@
+@@ -2682,7 +2682,7 @@
* Module: library/xtea.c
* Caller:
*/
a> 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769 770 771 772 773 774 775 776 777 778 779 780 781 782 783 784 785 786 787 788 789 790 791 792 793 794 795 796 797 798 799 800 801 802 803 804 805 806 807 808 809 810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825 826 827 828 829 830 831 832 833 834 835 836 837 838 839 840 841 842 843 844 845 846 847 848 849 850 851 852 853 854 855 856 857 858 859 860 861 862 863 864 865 866 867 868 869 870 871 872 873 874 875 876 877 878 879 880 881 882 883 884 885 886 887 888 889 890 891 892 893 894 895 896 897 898 899 900 901 902 903 904 905 906 907 908 909 910 911 912 913 914 915 916 917 918 919 920 921 922 923 924 925 926 927 928 929 930 931 932 933 934 935 936 937 938 939 940 941 942 943 944 945 946 947 948 949 950 951 952 953 954 955 956 957 958 959 960 961 962 963 964 965 966 967 968 969 970 971 972 973 974 975 976 977 978 979 980 981 982 983 984 985 986 987 988 989 990 991 992 993 994 995 996 997 998 999 1000 1001 1002 1003 1004 1005 1006 1007 1008 1009 1010 1011 1012 1013 1014 1015 1016 1017 1018 1019 1020 1021 1022 1023 1024 1025 1026 1027 1028 1029 1030 1031 1032 1033 1034 1035 1036 1037 1038 1039 1040 1041 1042 1043 1044 1045 1046 1047 1048 1049 1050 1051 1052 1053 1054 1055 1056 1057 1058 1059 1060 1061 1062 1063 1064 1065 1066 1067 1068 1069 1070 1071 1072 1073 1074 1075 1076 1077 1078 1079 1080 1081 1082 1083 1084 1085 1086 1087 1088 1089 1090 1091 1092 1093 1094 1095 1096 1097 1098 1099 1100 1101 1102 1103 1104 1105 1106 1107 1108 1109 1110 1111 1112 1113 1114 1115 1116 1117 1118 1119 1120 1121 1122 1123 1124 1125 1126 1127 1128 1129