aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorCezary Jackiewicz <cezary@eko.one.pl>2022-02-27 14:12:39 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-04-17 21:31:02 +0200
commit0a5f3b012669208f5454ebe4a1def16e5ab093dd (patch)
treeadf20e50c89c4ef01c95650102c3672e2c5e3440 /package/network
parent83003b6c066049fc68be802dfb25449753cb4671 (diff)
downloadupstream-0a5f3b012669208f5454ebe4a1def16e5ab093dd.tar.gz
upstream-0a5f3b012669208f5454ebe4a1def16e5ab093dd.tar.bz2
upstream-0a5f3b012669208f5454ebe4a1def16e5ab093dd.zip
comgt: support ZTE MF286R modem
The modem is based on Marvell PXA1826 and uses ACM+RNDIS interface to establish connection with custom commands specific to ZTE modems. Two variants of modems were discovered, some identifying themselves as "ZTE", and others as plain "Marvell", the chipset manufacturer. The modem itself runs a fork of OpenWrt inside, which root shell can be accessed via ADB interface. Signed-off-by: Cezary Jackiewicz <cezary@eko.one.pl> Signed-off-by: Lech Perczak <lech.perczak@gmail.com> (cherry picked from commit e02fb42c53bad5dd36726c6ef5a46bfe31d2e400)
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/comgt/Makefile2
-rw-r--r--package/network/utils/comgt/files/ncm.json22
2 files changed, 23 insertions, 1 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index db5ea57473..24dae2521e 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=comgt
PKG_VERSION:=0.32
-PKG_RELEASE:=33
+PKG_RELEASE:=34
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/comgt
diff --git a/package/network/utils/comgt/files/ncm.json b/package/network/utils/comgt/files/ncm.json
index bbdb30c5ee..b6ad717529 100644
--- a/package/network/utils/comgt/files/ncm.json
+++ b/package/network/utils/comgt/files/ncm.json
@@ -74,5 +74,27 @@
"connect": "AT+CGACT=1,${profile}",
"finalize": "AT+CGDATA=\\\"M-MBIM\\\",${profile},1",
"disconnect": "AT+CGACT=0,${profile}"
+ },
+ "\"zte": {
+ "initialize": [
+ "AT+CFUN=1"
+ ],
+ "configure": [
+ "AT+ZGDCONT=${profile},\\\"${pdptype}\\\",\\\"${apn}\\\",\\\"\\\",0,0",
+ "AT+ZGPCOAUTH=${profile},\\\"${username}\\\",\\\"${password}\\\",0"
+ ],
+ "connect": "AT+ZGACT=1,${profile}",
+ "disconnect": "AT+ZGACT=0,${profile}"
+ },
+ "\"marvell\"": {
+ "initialize": [
+ "AT+CFUN=1"
+ ],
+ "configure": [
+ "AT+ZGDCONT=${profile},\\\"${pdptype}\\\",\\\"${apn}\\\",\\\"\\\",0,0",
+ "AT+ZGPCOAUTH=${profile},\\\"${username}\\\",\\\"${password}\\\",0"
+ ],
+ "connect": "AT+ZGACT=1,${profile}",
+ "disconnect": "AT+ZGACT=0,${profile}"
}
}