aboutsummaryrefslogtreecommitdiffstats
path: root/package/pjsip/patches/000-aconf.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-11-11 22:23:26 +0000
committerJohn Crispin <blogic@openwrt.org>2011-11-11 22:23:26 +0000
commit5a34f62218c5e932b3fec0cf12a32f1025d8e4ad (patch)
treed3031540135a97ac8ee5db76dd54e9ecb650c4d5 /package/pjsip/patches/000-aconf.patch
parent796b2be4f5f2c227f9aa427dd75186e5fc9254f1 (diff)
downloadupstream-5a34f62218c5e932b3fec0cf12a32f1025d8e4ad.tar.gz
upstream-5a34f62218c5e932b3fec0cf12a32f1025d8e4ad.tar.bz2
upstream-5a34f62218c5e932b3fec0cf12a32f1025d8e4ad.zip
pjsip: bump to 1.10 and improve ltq_tapi backend
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28963 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/pjsip/patches/000-aconf.patch')
-rw-r--r--package/pjsip/patches/000-aconf.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/package/pjsip/patches/000-aconf.patch b/package/pjsip/patches/000-aconf.patch
index 96c519aea0..46e4aad4ac 100644
--- a/package/pjsip/patches/000-aconf.patch
+++ b/package/pjsip/patches/000-aconf.patch
@@ -1,15 +1,18 @@
--- a/aconfigure.ac
+++ b/aconfigure.ac
-@@ -48,7 +48,7 @@
+@@ -48,9 +48,9 @@ if test -z "$CROSS_COMPILE"; then
CROSS_COMPILE=`echo ${CC} | sed 's/gcc//'`
fi
-if test "$AR" = ""; then AR="${CROSS_COMPILE}ar rv"; fi
+AR="${CROSS_COMPILE}ar rv"
AC_SUBST(AR)
- if test "$LD" = ""; then LD="$CC"; fi
+-if test "$LD" = ""; then LD="$CC"; fi
++LD="${CROSS_COMPILE}gcc"
AC_SUBST(LD)
-@@ -590,6 +590,15 @@
+ if test "$LDOUT" = ""; then LDOUT="-o"; fi
+ AC_SUBST(LDOUT)
+@@ -597,6 +597,15 @@ AC_ARG_ENABLE(ext_sound,
AC_MSG_RESULT([Checking if external sound is set... yes])
fi]
)
@@ -27,7 +30,7 @@
AC_SUBST(ac_no_small_filter)
--- a/pjmedia/build/os-auto.mak.in
+++ b/pjmedia/build/os-auto.mak.in
-@@ -118,4 +118,11 @@
+@@ -118,4 +118,11 @@ ifeq ($(AC_PJMEDIA_SND),external)
export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_PORTAUDIO=0 -DPJMEDIA_AUDIO_DEV_HAS_WMME=0
endif