aboutsummaryrefslogtreecommitdiffstats
path: root/package/relayd/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-02-25 23:23:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-02-25 23:23:40 +0000
commitc16efad4287cd0ec5731058b21aedd2c899bebf1 (patch)
tree81ea4fd6ff49d56d59453bc6cda803a3970bb337 /package/relayd/Makefile
parent73468de8d1fad601c5dc6460cc33c02af47c51f8 (diff)
downloadupstream-c16efad4287cd0ec5731058b21aedd2c899bebf1.tar.gz
upstream-c16efad4287cd0ec5731058b21aedd2c899bebf1.tar.bz2
upstream-c16efad4287cd0ec5731058b21aedd2c899bebf1.zip
relayd: add uci integration
SVN-Revision: 25714
Diffstat (limited to 'package/relayd/Makefile')
-rw-r--r--package/relayd/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/relayd/Makefile b/package/relayd/Makefile
index b17d40049c..1881da928a 100644
--- a/package/relayd/Makefile
+++ b/package/relayd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -32,6 +32,10 @@ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
define Package/relayd/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/relayd $(1)/usr/sbin/relayd
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/relay.hotplug $(1)/etc/hotplug.d/iface/30-relay
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files/relay.sh $(1)/lib/network/relay.sh
endef
$(eval $(call BuildPackage,relayd))
95' href='#n195'>195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340