aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ubox/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-03-12 19:32:51 +0000
committerJohn Crispin <blogic@openwrt.org>2014-03-12 19:32:51 +0000
commit2b77148377660a48e047f0ef626ca16c8df286fe (patch)
tree3f37e0752f9e67f7620b9dae11be8a5259e029c0 /package/system/ubox/Makefile
parent3b45a0d59f2236ba21f7671b4416b01e5b1b82a8 (diff)
downloadupstream-2b77148377660a48e047f0ef626ca16c8df286fe.tar.gz
upstream-2b77148377660a48e047f0ef626ca16c8df286fe.tar.bz2
upstream-2b77148377660a48e047f0ef626ca16c8df286fe.zip
fstools: add the new fstools package
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39895 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/ubox/Makefile')
-rw-r--r--package/system/ubox/Makefile27
1 files changed, 2 insertions, 25 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index b3a4ba9eea..5bd7246858 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -28,22 +28,13 @@ define Package/ubox
TITLE:=OpenWrt system helper toolbox
endef
-define Package/block-mount
- SECTION:=base
- CATEGORY:=Base system
- TITLE:=Block device mounting and checking
- DEPENDS:=+ubox +libubox +libuci
-endef
-
define Package/ubox/install
$(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/ $(1)/etc/init.d/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,logd,logread,validate_data} $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{kmodloader,logd,logread,validate_data} $(1)/sbin/
$(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib
- ln -s /sbin/mount_root $(1)/sbin/switch2jffs
- ln -s /sbin/mount_root $(1)/sbin/jffs2reset
- ln -s /sbin/mount_root $(1)/sbin/jffs2mark
+
ln -s /sbin/kmodloader $(1)/usr/sbin/rmmod
ln -s /sbin/kmodloader $(1)/usr/sbin/insmod
ln -s /sbin/kmodloader $(1)/usr/sbin/lsmod
@@ -51,18 +42,4 @@ define Package/ubox/install
ln -s /sbin/kmodloader $(1)/usr/sbin/modprobe
endef
-define Package/block-mount/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
-
- $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
- $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
- $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
-
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
- ln -s /sbin/block $(1)/usr/sbin/swapon
- ln -s /sbin/block $(1)/usr/sbin/swapoff
-
-endef
-
$(eval $(call BuildPackage,ubox))
-$(eval $(call BuildPackage,block-mount))