aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-27 22:50:32 +0100
committerPetr Štetiar <ynezz@true.cz>2020-12-05 20:50:19 +0100
commit5abe98947542cd9374912f895f057fe56f7036b8 (patch)
treeaa9ae9d8d88616e024477a6c63397bb8ec6aba9b /rules.mk
parent77734ce82a8fdc88b88cb1244d6e2f54eeb773b0 (diff)
downloadupstream-5abe98947542cd9374912f895f057fe56f7036b8.tar.gz
upstream-5abe98947542cd9374912f895f057fe56f7036b8.tar.bz2
upstream-5abe98947542cd9374912f895f057fe56f7036b8.zip
cmake.mk,rules.mk: fix host builds using CMake and ccache
Commit f98878e4c17d ("cmake.mk: set C/CXX compiler for host builds as well") has introduced regression as it didn't taken usage of ccache into the account so fix it by handling ccache use cases as well. In order to get this working we need to export HOSTCXX_NOCACHE in rules.mk as well. Fixes: f98878e4c17d ("cmake.mk: set C/CXX compiler for host builds as well") Reported-by: Ansuel Smith <ansuelsmth@gmail.com> Tested-by: Ansuel Smith <ansuelsmth@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 524fb5646eec6147aadfdd508219f39bcf8ba8fc)
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 80cb3d63f4..41ed9bafd0 100644
--- a/rules.mk
+++ b/rules.mk
@@ -291,6 +291,7 @@ HOSTCXX_NOCACHE:=$(HOSTCXX)
export TARGET_CC_NOCACHE
export TARGET_CXX_NOCACHE
export HOSTCC_NOCACHE
+export HOSTCXX_NOCACHE
ifneq ($(CONFIG_CCACHE),)
TARGET_CC:= ccache_cc