aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-10-12 15:36:33 -1000
committerPaul Spooren <mail@aparcar.org>2021-11-05 19:18:48 -1000
commit15e55a2190ba087679b24b8844a51a6e4d512cf3 (patch)
treebffb2302ab2fbbd5ddd1032a2f4c2d7f59d7258f /target/imagebuilder/Makefile
parent81832b38a0833290ad794065f4bde07df271beb1 (diff)
downloadupstream-15e55a2190ba087679b24b8844a51a6e4d512cf3.tar.gz
upstream-15e55a2190ba087679b24b8844a51a6e4d512cf3.tar.bz2
upstream-15e55a2190ba087679b24b8844a51a6e4d512cf3.zip
imagebuilder: fix local packages/ folder
This commit fixes commit "2999f810ff: build,IB: include kmods only in local builds" which cause the local packages/ folder only to be added for local builds but no longer for ImageBuilder created by the Buildbot. The commits intention was to use remote kmods repositories rather than storing them locally. Accidentally the entire handling of the local `packages/` was removed. Re-add the folder and include a README describing what it can be used for. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/imagebuilder/Makefile')
-rw-r--r--target/imagebuilder/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 0580e41c57..8607a2d709 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -46,12 +46,16 @@ ifeq ($(CONFIG_IB_STANDALONE),)
$(VERSION_SED_SCRIPT) $(PKG_BUILD_DIR)/repositories.conf
endif
-ifeq ($(CONFIG_BUILDBOT),)
$(INSTALL_DIR) $(PKG_BUILD_DIR)/packages
+ # create an empty package index so `opkg` doesn't report an error
+ touch $(PKG_BUILD_DIR)/packages/Packages
+ $(INSTALL_DATA) ./files/README.md $(PKG_BUILD_DIR)/packages/
+
echo '' >> $(PKG_BUILD_DIR)/repositories.conf
echo '## This is the local package repository, do not remove!' >> $(PKG_BUILD_DIR)/repositories.conf
echo 'src imagebuilder file:packages' >> $(PKG_BUILD_DIR)/repositories.conf
+ifeq ($(CONFIG_BUILDBOT),)
ifeq ($(CONFIG_IB_STANDALONE),)
$(FIND) $(call FeedPackageDir,libc) -type f \
\( -name 'libc_*.ipk' -or -name 'kernel_*.ipk' -or -name 'kmod-*.ipk' \) \