aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2022-08-03 17:31:03 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-05 11:12:32 +0200
commitf32085fc0b87049491b07e198d924d738a1a2834 (patch)
tree5383b5ef246e08830738801a12a6e8dc76b39c53 /target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch
parentf1802b0db7e22f98e1718e2c8bec29b2842f5aea (diff)
downloadupstream-f32085fc0b87049491b07e198d924d738a1a2834.tar.gz
upstream-f32085fc0b87049491b07e198d924d738a1a2834.tar.bz2
upstream-f32085fc0b87049491b07e198d924d738a1a2834.zip
airoha: Add new target platform
Airoha is a new ARM platform based on Cortex-A53 which has recently been merged into linux-next. Due to BootROM limitations on this platform, the Cortex-A53 can't run in Aarch64 mode and code must be compiled for 32-Bit ARM. This support is based mostly on those linux-next commits backported for kernel 5.15. Patches: 1 - platform support = linux-next 2 - clock driver = linux-next 3 - gpio driver = linux-next 4 - linux,usable-memory-range dts support = linux-next 5 - mtd spinand driver 6 - spi driver 7 - pci driver (kconfig only, uses mediatek PCI) = linux-next Still missing: - Ethernet driver - Sysupgrade support A.t.m there exists one subtarget EN7523 with only one evaluation board. The initramfs can be run with the following commands from u-boot: - u-boot> setenv bootfile \ openwrt-airoha-airoha_en7523-evb-initramfs-kernel.bin u-boot> tftpboot u-boot> bootm 0x81800000 - Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
Diffstat (limited to 'target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch')
-rw-r--r--target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch b/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch
new file mode 100644
index 0000000000..b1f88a6ac7
--- /dev/null
+++ b/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch
@@ -0,0 +1,35 @@
+diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
+index 66f5d6c3..05cd3385 100644
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -571,6 +571,18 @@ config ARCH_VIRT
+ select HAVE_ARM_ARCH_TIMER
+ select ARCH_SUPPORTS_BIG_ENDIAN
+
++config ARCH_AIROHA
++ bool "Airoha SoC Support"
++ depends on ARCH_MULTI_V7
++ select ARM_AMBA
++ select ARM_GIC
++ select ARM_GIC_V3
++ select ARM_PSCI
++ select HAVE_ARM_ARCH_TIMER
++ select COMMON_CLK
++ help
++ Support for Airoha EN7523 SoCs
++
+ #
+ # This is sorted alphabetically by mach-* pathname. However, plat-*
+ # Kconfigs may be included either alphabetically (according to the
+diff --git a/arch/arm/Makefile b/arch/arm/Makefile
+index fa45837b..c34f7463 100644
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -156,6 +156,7 @@ textofs-$(CONFIG_ARCH_AXXIA) := 0x00308000
+ # Machine directory name. This list is sorted alphanumerically
+ # by CONFIG_* macro name.
+ machine-$(CONFIG_ARCH_ACTIONS) += actions
++machine-$(CONFIG_ARCH_AIROHA) += airoha
+ machine-$(CONFIG_ARCH_ALPINE) += alpine
+ machine-$(CONFIG_ARCH_ARTPEC) += artpec
+ machine-$(CONFIG_ARCH_ASPEED) += aspeed