aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a53.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-06 00:47:18 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:19:51 +0100
commit3a4ad758f537bd4cc24163f76d2865179484541c (patch)
treefbfe4f4cf2c30fda3aa591517a7bc9ba0e727505 /target/linux/sunxi/image/cortex-a53.mk
parenta4cdb537b17ede9785ddbaef5ed9d69f3ab89052 (diff)
downloadupstream-3a4ad758f537bd4cc24163f76d2865179484541c.tar.gz
upstream-3a4ad758f537bd4cc24163f76d2865179484541c.tar.bz2
upstream-3a4ad758f537bd4cc24163f76d2865179484541c.zip
sunxi: construct DTS name from device node name and SOC
The device part in the SUNXI_DTS variable always corresponds to device node name. This is another redundancy that can be removed by calculating the DTS name from a newly introduced SUNXI_SOC variable and the node name. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a53.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk18
1 files changed, 12 insertions, 6 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index d6c17d95ff..b0d087b9b1 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -11,7 +11,8 @@ define Device/friendlyarm_nanopi-neo-plus2
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi NEO Plus2
SUPPORTED_DEVICES:=nanopi-neo-plus2
- SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo-plus2
+ SUNXI_DTS_DIR := allwinner/
+ SUNXI_SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -22,7 +23,8 @@ define Device/friendlyarm_nanopi-neo2
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi NEO2
SUPPORTED_DEVICES:=nanopi-neo2
- SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo2
+ SUNXI_DTS_DIR := allwinner/
+ SUNXI_SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -32,7 +34,8 @@ TARGET_DEVICES += friendlyarm_nanopi-neo2
define Device/pine64_pine64-plus
DEVICE_VENDOR := Pine64
DEVICE_MODEL := Pine64+
- SUNXI_DTS:=allwinner/sun50i-a64-pine64-plus
+ SUNXI_DTS_DIR := allwinner/
+ SUNXI_SOC := sun50i-a64
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -42,7 +45,8 @@ TARGET_DEVICES += pine64_pine64-plus
define Device/pine64_sopine-baseboard
DEVICE_VENDOR := Pine64
DEVICE_MODEL := SoPine
- SUNXI_DTS:=allwinner/sun50i-a64-sopine-baseboard
+ SUNXI_DTS_DIR := allwinner/
+ SUNXI_SOC := sun50i-a64
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -53,7 +57,8 @@ TARGET_DEVICES += pine64_sopine-baseboard
define Device/xunlong_orangepi-zero-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Zero Plus
- SUNXI_DTS:=allwinner/sun50i-h5-orangepi-zero-plus
+ SUNXI_DTS_DIR := allwinner/
+ SUNXI_SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
@@ -63,7 +68,8 @@ TARGET_DEVICES += xunlong_orangepi-zero-plus
define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC 2
- SUNXI_DTS:=allwinner/sun50i-h5-orangepi-pc2
+ SUNXI_DTS_DIR := allwinner/
+ SUNXI_SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef