aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:52 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:52 +0000
commit0669f69d5c953b659b89e07e7ce333f8b85fec11 (patch)
tree597900e8af687cc178e3f5cf82b95d97eb5254cf /target
parent15af03f306ec3f887adbc21445d0e7e9c15b4258 (diff)
downloadupstream-0669f69d5c953b659b89e07e7ce333f8b85fec11.tar.gz
upstream-0669f69d5c953b659b89e07e7ce333f8b85fec11.tar.bz2
upstream-0669f69d5c953b659b89e07e7ce333f8b85fec11.zip
ramips: enable second SPI for VoCore
This patch enables the second SPI as spidev and also fixes some typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Backport of r42277 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42378 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/VOCORE.dts19
-rw-r--r--target/linux/ramips/rt305x/profiles/vocore.mk3
2 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/ramips/dts/VOCORE.dts b/target/linux/ramips/dts/VOCORE.dts
index e5df9abb42..e6288b03b8 100644
--- a/target/linux/ramips/dts/VOCORE.dts
+++ b/target/linux/ramips/dts/VOCORE.dts
@@ -22,14 +22,14 @@
#address-cells = <1>;
#size-cells = <1>;
compatible = "s25fl064k";
- reg = <0 0>;
+ reg = <0>;
linux,modalias = "m25p80", "s25fl064k";
spi-max-frequency = <10000000>;
partition@0 {
label = "uboot";
reg = <0x0 0x30000>;
- read_only;
+ read-only;
};
partition@30000 {
@@ -49,13 +49,19 @@
reg = <0x50000 0x7b0000>;
};
};
+
+ spidev@1 {
+ compatible = "linux,spidev";
+ spi-max-frequency = <10000000>;
+ reg = <1>;
+ };
};
};
pinctrl {
state_default: pinctrl0 {
gpio {
- ralink,group = "jtag", "uartf", "led", "spi_cs1";
+ ralink,group = "jtag", "uartf", "led";
ralink,function = "gpio";
};
};
@@ -192,13 +198,6 @@
gpio-export,direction_may_change = <1>;
gpios = <&gpio1 4 0>;
};
-
- /* SPI_CS1 */
- gpio27 {
- gpio-export,name = "gpio27";
- gpio-export,direction_may_change = <1>;
- gpios = <&gpio1 5 0>;
- };
};
gpio-leds {
diff --git a/target/linux/ramips/rt305x/profiles/vocore.mk b/target/linux/ramips/rt305x/profiles/vocore.mk
index 11fb634beb..92f3ce58ed 100644
--- a/target/linux/ramips/rt305x/profiles/vocore.mk
+++ b/target/linux/ramips/rt305x/profiles/vocore.mk
@@ -9,7 +9,8 @@ define Profile/VOCORE
NAME:=VoCore
PACKAGES:=\
kmod-usb-core kmod-usb-ohci kmod-usb2 \
- kmod-i2c-core kmod-i2c-ralink
+ kmod-i2c-core kmod-i2c-ralink \
+ kmod-spi-dev
endef
define Profile/VOCORE/Description