aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/rarpd
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/rarpd')
-rw-r--r--openwrt/package/rarpd/Config.in14
-rw-r--r--openwrt/package/rarpd/Makefile79
-rw-r--r--openwrt/package/rarpd/files/rarpd.default4
-rw-r--r--openwrt/package/rarpd/files/rarpd.init7
-rw-r--r--openwrt/package/rarpd/ipkg/rarpd.conffiles1
-rw-r--r--openwrt/package/rarpd/ipkg/rarpd.control5
6 files changed, 0 insertions, 110 deletions
diff --git a/openwrt/package/rarpd/Config.in b/openwrt/package/rarpd/Config.in
deleted file mode 100644
index 648866938d..0000000000
--- a/openwrt/package/rarpd/Config.in
+++ /dev/null
@@ -1,14 +0,0 @@
-config BR2_PACKAGE_RARPD
- prompt "rarpd............................. Reverse ARP Daemon"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBNET
- help
- Rarpd is a daemon which responds to RARP requests.
- RARP is used by some machines at boot time to discover their
- IP address. They provide their Ethernet address and rarpd
- responds with their IP address if it finds it in the ethers
- database.
-
- ftp://ftp.dementia.org/pub/net-tools/
-
diff --git a/openwrt/package/rarpd/Makefile b/openwrt/package/rarpd/Makefile
deleted file mode 100644
index b91cd83a43..0000000000
--- a/openwrt/package/rarpd/Makefile
+++ /dev/null
@@ -1,79 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=rarpd
-PKG_VERSION:=1.1
-PKG_RELEASE:=1
-PKG_MD5SUM:=04e2ca849e758d0b88c8281775ec3b58
-
-PKG_SOURCE_URL:=ftp://ftp.dementia.org/pub/net-tools
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-# Hack Alert!
-# The configure script for rarpd, when used with the --with-libnet option
-# doesn't correctly detect and set -DNEW_LIBNET_INTERFACE.
-EXTRA_CFLAGS = -DNEW_LIBNET_INTERFACE
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,RARPD,rarpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-I$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --with-libnet="$(STAGING_DIR)/usr" \
- --with-pcap="$(STAGING_DIR)/usr" \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_RARPD):
- install -d -m0755 $(IDIR_RARPD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/rarpd $(IDIR_RARPD)/usr/sbin/
- install -d -m0755 $(IDIR_RARPD)/etc/default
- install -m644 ./files/rarpd.default $(IDIR_RARPD)/etc/default/rarpd
- install -d -m0755 $(IDIR_RARPD)/etc/init.d
- install -m755 ./files/rarpd.init $(IDIR_RARPD)/etc/init.d/rarpd
- ln -sf rarpd $(IDIR_RARPD)/etc/init.d/S50rarpd
- $(RSTRIP) $(IDIR_RARPD)
- $(IPKG_BUILD) $(IDIR_RARPD) $(PACKAGE_DIR)
-
-mostlyclean:
- -$(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/rarpd/files/rarpd.default b/openwrt/package/rarpd/files/rarpd.default
deleted file mode 100644
index 1dd41e9b37..0000000000
--- a/openwrt/package/rarpd/files/rarpd.default
+++ /dev/null
@@ -1,4 +0,0 @@
-# /etc/default/rarpd
-#
-# Only listen on vlan0
-#OPTIONS="-i vlan0"
diff --git a/openwrt/package/rarpd/files/rarpd.init b/openwrt/package/rarpd/files/rarpd.init
deleted file mode 100644
index 04ca0b4f38..0000000000
--- a/openwrt/package/rarpd/files/rarpd.init
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-RARPD=/usr/sbin/rarpd
-DEFAULT=/etc/default/rarpd
-[ -f $DEFAULT ] && . $DEFAULT
-
-$RARPD $OPTIONS
diff --git a/openwrt/package/rarpd/ipkg/rarpd.conffiles b/openwrt/package/rarpd/ipkg/rarpd.conffiles
deleted file mode 100644
index 067611849b..0000000000
--- a/openwrt/package/rarpd/ipkg/rarpd.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/default/rarpd
diff --git a/openwrt/package/rarpd/ipkg/rarpd.control b/openwrt/package/rarpd/ipkg/rarpd.control
deleted file mode 100644
index 221e869af2..0000000000
--- a/openwrt/package/rarpd/ipkg/rarpd.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: rarpd
-Priority: optional
-Section: net
-Depends: libnet
-Description: Reverse ARP Daemon