aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-ar71xx/src/board/zyxel/nbg460n')
-rw-r--r--package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/Makefile46
-rw-r--r--package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/config.mk1
-rw-r--r--package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/lowlevel_init.S39
-rw-r--r--package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/nbg460n.c96
-rw-r--r--package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/u-boot.lds42
5 files changed, 0 insertions, 224 deletions
diff --git a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/Makefile b/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/Makefile
deleted file mode 100644
index b0a385babf..0000000000
--- a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# (C) Copyright 2003-2008
-# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
-#
-# See file CREDITS for list of people who contributed to this
-# project.
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of
-# the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
-# MA 02111-1307 USA
-#
-
-include $(TOPDIR)/config.mk
-
-LIB = $(obj)lib$(BOARD).a
-
-COBJS-y += $(BOARD).o
-SOBJS-y += lowlevel_init.o
-
-SRCS := $(SOBJS-y:.o=.S) $(COBJS-y:.o=.c)
-OBJS := $(addprefix $(obj),$(COBJS-y))
-SOBJS := $(addprefix $(obj),$(SOBJS-y))
-
-$(LIB): $(obj).depend $(OBJS) $(SOBJS)
- $(AR) $(ARFLAGS) $@ $(OBJS) $(SOBJS)
-
-
-#########################################################################
-
-# defines $(obj).depend target
-include $(SRCTREE)/rules.mk
-
-sinclude $(obj).depend
-
-#########################################################################
diff --git a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/config.mk b/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/config.mk
deleted file mode 100644
index e042e78bf8..0000000000
--- a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/config.mk
+++ /dev/null
@@ -1 +0,0 @@
-TEXT_BASE = 0x81E00000
diff --git a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/lowlevel_init.S b/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/lowlevel_init.S
deleted file mode 100644
index 83084c8d48..0000000000
--- a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/lowlevel_init.S
+++ /dev/null
@@ -1,39 +0,0 @@
-/*
- * (C) Copyright 2010
- * Michael Kurz <michi.kurz@googlemail.com>.
- *
- * See file CREDITS for list of people who contributed to this
- * project.
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation; either version 2 of
- * the License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
- * MA 02111-1307 USA
- */
-
-#include <config.h>
-#include <version.h>
-#include <asm/regdef.h>
-#include <asm/mipsregs.h>
-#include <asm/addrspace.h>
-
-
-
-.globl lowlevel_init
-/*
- All done by Bootbase, nothing to do
-*/
-lowlevel_init:
- jr ra
- nop
-
diff --git a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/nbg460n.c b/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/nbg460n.c
deleted file mode 100644
index 03a479d522..0000000000
--- a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/nbg460n.c
+++ /dev/null
@@ -1,96 +0,0 @@
-/*
- * (C) Copyright 2010
- * Michael Kurz <michi.kurz@googlemail.com>.
- *
- * See file CREDITS for list of people who contributed to this
- * project.
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation; either version 2 of
- * the License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
- * MA 02111-1307 USA
- */
-
-#include <common.h>
-#include <netdev.h>
-#include <asm/mipsregs.h>
-#include <asm/addrspace.h>
-#include <asm/reboot.h>
-#include <asm/ar71xx.h>
-#include <asm/ar71xx_gpio.h>
-
-#define NBG460N_WAN_LED 19
-
-phys_size_t initdram(int board_type)
-{
- return (32*1024*1024);
-}
-
-int checkboard(void)
-{
- // Set pin 19 to 1, to stop WAN LED blinking
- ar71xx_setpindir(NBG460N_WAN_LED, 1);
- ar71xx_setpin(NBG460N_WAN_LED, 1);
-
- printf("U-boot on Zyxel NBG460N\n");
- return 0;
-}
-
-void _machine_restart(void)
-{
- for (;;) {
- writel((RESET_MODULE_FULL_CHIP | RESET_MODULE_DDR),
- KSEG1ADDR(AR71XX_RESET_BASE + AR91XX_RESET_REG_RESET_MODULE));
- readl(KSEG1ADDR(AR71XX_RESET_BASE + AR91XX_RESET_REG_RESET_MODULE));
- }
-}
-
-int board_eth_init(bd_t *bis)
-{
- char *phynames[] = {RTL8366_DEVNAME, RTL8366_DEVNAME};
- u16 phyids[] = {RTL8366_LANPHY_ID, RTL8366_WANPHY_ID};
- u16 phyfixed[] = {1, 0};
-
- if (ag71xx_register(bis, phynames, phyids, phyfixed) <= 0)
- return -1;
-
- if (rtl8366s_initialize())
- return -1;
-
- if (rtl8366_mii_register(bis))
- return -1;
-
- return 0;
-}
-
-int misc_init_r(void) {
- uint8_t macaddr[6];
- uint8_t enetaddr[6];
-
- debug("Testing mac addresses\n");
-
- memcpy(macaddr, (uint8_t *) CONFIG_ETHADDR_ADDR, 6);
-
- if (!eth_getenv_enetaddr("ethaddr", enetaddr)) {
- debug("Setting eth0 mac addr to %pM\n", macaddr);
- eth_setenv_enetaddr("ethaddr", macaddr);
- }
-
- if (!eth_getenv_enetaddr("eth1addr", enetaddr)) {
- macaddr[5] += 1;
- debug("Setting eth1 mac addr to %pM\n", macaddr);
- eth_setenv_enetaddr("eth1addr", macaddr);
- }
-
- return 0;
-}
diff --git a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/u-boot.lds b/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/u-boot.lds
deleted file mode 100644
index 8dc2b764c7..0000000000
--- a/package/boot/uboot-ar71xx/src/board/zyxel/nbg460n/u-boot.lds
+++ /dev/null
@@ -1,42 +0,0 @@
-OUTPUT_FORMAT("elf32-tradbigmips", "elf32-tradbigmips", "elf32-tradbigmips")
-OUTPUT_ARCH(mips)
-ENTRY(_start)
-SECTIONS
-{
- . = 0x00000000;
-
- . = ALIGN(4);
- .text :
- {
- *(.text)
- }
-
- . = ALIGN(4);
- .rodata : { *(.rodata) }
-
- . = ALIGN(4);
- .data : { *(.data) }
-
- . = ALIGN(4);
- .sdata : { *(.sdata) }
-
- _gp = ALIGN(16);
-
- __got_start = .;
- .got : { *(.got) }
- __got_end = .;
-
- .sdata : { *(.sdata) }
-
- __u_boot_cmd_start = .;
- .u_boot_cmd : { *(.u_boot_cmd) }
- __u_boot_cmd_end = .;
-
- uboot_end_data = .;
- num_got_entries = (__got_end - __got_start) >> 2;
-
- . = ALIGN(4);
- .sbss : { *(.sbss) }
- .bss : { *(.bss) }
- uboot_end = .;
-}