aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 68e4ba498b..2c95377b0f 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -30,9 +30,23 @@ define U-Boot/at91sam9x5ek_nandflash
BUILD_SUBTARGET:=legacy
endef
+define uboot/sama5d3_xplained_nandflash
+ TITLE:=U-Boot for the SAMA5D3 Xplained board (NandFlash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
+define uboot/sama5d3_xplained_mmc
+ TITLE:=U-Boot for the SAMA5D3 Xplained board (SDcard)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
- at91sam9x5ek_nandflash
+ at91sam9x5ek_nandflash \
+ sama5d3_xplained_nandflash \
+ sama5d3_xplained_mmc
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \