aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/patches/100-fix-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-mvebu/patches/100-fix-build.patch')
-rw-r--r--package/boot/uboot-mvebu/patches/100-fix-build.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/patches/100-fix-build.patch b/package/boot/uboot-mvebu/patches/100-fix-build.patch
new file mode 100644
index 0000000000..c39f5bf1dc
--- /dev/null
+++ b/package/boot/uboot-mvebu/patches/100-fix-build.patch
@@ -0,0 +1,20 @@
+The build fails on a sunxi tool:
+
+/usr/bin/ld: tools/sunxi_toc0.o: in function `toc0_set_header':
+sunxi_toc0.c:(.text+0x363): undefined reference to `RSA_get0_d'
+
+The missing function was added in libressl v3.5.0. We don't
+really care, so just cut it out for now.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -96,8 +96,7 @@ AES_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := $(
+
+ # Cryptographic helpers and image types that depend on openssl/libcrypto
+ LIBCRYPTO_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := \
+- lib/fdt-libcrypto.o \
+- sunxi_toc0.o
++ lib/fdt-libcrypto.o
+
+ ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
+