aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/ath10k-ct/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/ath10k-ct/Makefile')
-rw-r--r--package/kernel/ath10k-ct/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index 366515189a..d39ecabf46 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -37,6 +37,14 @@ define KernelPackage/ath10k-ct
PROVIDES:=kmod-ath10k
endef
+define KernelPackage/ath10k-ct/config
+
+ config ATH10K-CT_LEDS
+ bool "Enable LED support"
+ default y
+ depends on PACKAGE_kmod-ath10k-ct
+endef
+
NOSTDINC_FLAGS = \
-I$(PKG_BUILD_DIR) \
-I$(STAGING_DIR)/usr/include/mac80211-backport/uapi \
@@ -77,6 +85,11 @@ ifdef CONFIG_PACKAGE_ATH_SPECTRAL
NOSTDINC_FLAGS += -DCONFIG_ATH10K_SPECTRAL
endif
+ifeq ($(CONFIG_ATH10K-CT_LEDS),y)
+ CT_MAKEDEFS += CONFIG_ATH10K_LEDS=y
+ NOSTDINC_FLAGS += -DCONFIG_ATH10K_LEDS
+endif
+
define Build/Configure
cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
endef