aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/pcre/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
index 3655614169..bf3f733a5c 100644
--- a/package/libs/pcre/Makefile
+++ b/package/libs/pcre/Makefile
@@ -29,6 +29,7 @@ PKG_CONFIG_DEPENDS:=\
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/libpcre/default
SECTION:=libs
@@ -61,7 +62,6 @@ define Package/libpcrecpp
DEPENDS:=+libpcre $(CXX_DEPENDS)
endef
-include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += \
--enable-utf8 \
@@ -70,9 +70,6 @@ HOST_CONFIGURE_ARGS += \
--with-match-limit-recursion=16000 \
--enable-cpp
-$(eval $(call HostBuild))
-
-
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
@@ -129,3 +126,4 @@ $(eval $(call BuildPackage,libpcre))
$(eval $(call BuildPackage,libpcre16))
$(eval $(call BuildPackage,libpcre32))
$(eval $(call BuildPackage,libpcrecpp))
+$(eval $(call HostBuild))