aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-kirkwood/Makefile6
-rw-r--r--package/boot/uboot-kirkwood/patches/201-blackarmor-nas220.patch29
2 files changed, 35 insertions, 0 deletions
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index e1493bf0e8..1ed1743e21 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -59,6 +59,11 @@ define U-Boot/l-50
BUILD_DEVICES:=checkpoint_l-50
endef
+define U-Boot/nas220
+ NAME:=Seagate Blackarmor NAS220
+ BUILD_DEVICES:=seagate_blackarmor-nas220
+endef
+
define U-Boot/nsa310
NAME:=Zyxel NSA310
BUILD_DEVICES:=zyxel_nsa310b
@@ -95,6 +100,7 @@ UBOOT_TARGETS := \
ib62x0 ib62x0_second_stage \
iconnect iconnect_second_stage \
l-50 \
+ nas220 \
nsa310 \
nsa310s \
nsa325 \
diff --git a/package/boot/uboot-kirkwood/patches/201-blackarmor-nas220.patch b/package/boot/uboot-kirkwood/patches/201-blackarmor-nas220.patch
new file mode 100644
index 0000000000..50de4e7b82
--- /dev/null
+++ b/package/boot/uboot-kirkwood/patches/201-blackarmor-nas220.patch
@@ -0,0 +1,29 @@
+--- a/include/configs/nas220.h
++++ b/include/configs/nas220.h
+@@ -54,17 +54,22 @@
+ /*
+ * Default environment variables
+ */
+-#define CONFIG_BOOTCOMMAND ""
++#define CONFIG_BOOTCOMMAND \
++ "ubi part ubi; " \
++ "ubi read 0x800000 kernel; " \
++ "bootm 0x800000"
+
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "bootargs=console=ttyS0,115200\0" \
+ "mtdparts=mtdparts=orion_nand:0xa0000@0x0(uboot),"\
+ "0x010000@0xa0000(env),"\
+- "0x500000@0xc0000(uimage),"\
+- "0x1a40000@0x5c0000(rootfs)\0" \
++ "0x1e80000@0xc0000(ubi)\0"\
+ "mtdids=nand0=orion_nand\0"\
+ "autostart=no\0"\
+- "autoload=no\0"
++ "autoload=no\0"\
++ "ipaddr=10.4.50.165\0"\
++ "serverip=10.4.50.5\0"\
++ "bootdelay=3"
+
+ /*
+ * Ethernet Driver configuration