aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/firmware/cypress-nvram/Makefile8
-rw-r--r--package/kernel/bcm27xx-gpu-fw/Makefile (renamed from package/kernel/brcm2708-gpu-fw/Makefile)18
-rw-r--r--package/kernel/linux/modules/netdevices.mk4
-rw-r--r--package/kernel/mac80211/broadcom.mk2
-rw-r--r--package/utils/bcm27xx-userland/Makefile (renamed from package/utils/brcm2708-userland/Makefile)18
-rw-r--r--package/utils/bcm27xx-userland/patches/001-interface-vcms_host-cmake-fixes.patch (renamed from package/utils/brcm2708-userland/patches/001-interface-vcms_host-cmake-fixes.patch)0
6 files changed, 25 insertions, 25 deletions
diff --git a/package/firmware/cypress-nvram/Makefile b/package/firmware/cypress-nvram/Makefile
index 418a2b0d7e..ef4044c6d0 100644
--- a/package/firmware/cypress-nvram/Makefile
+++ b/package/firmware/cypress-nvram/Makefile
@@ -34,7 +34,7 @@ endef
define Package/cypress-nvram-43430-sdio-rpi-3b
$(Package/cypress-nvram-default)
TITLE:=CYW43430 NVRAM for Raspberry Pi 3B
- DEPENDS:=@TARGET_brcm2708
+ DEPENDS:=@TARGET_bcm27xx
endef
define Package/cypress-nvram-43430-sdio-rpi-3b/install
@@ -50,7 +50,7 @@ $(eval $(call BuildPackage,cypress-nvram-43430-sdio-rpi-3b))
define Package/cypress-nvram-43430-sdio-rpi-zero-w
$(Package/cypress-nvram-default)
TITLE:=CYW43430 NVRAM for Raspberry Pi Zero W
- DEPENDS:=@TARGET_brcm2708
+ DEPENDS:=@TARGET_bcm27xx
endef
define Package/cypress-nvram-43430-sdio-rpi-zero-w/install
@@ -66,7 +66,7 @@ $(eval $(call BuildPackage,cypress-nvram-43430-sdio-rpi-zero-w))
define Package/cypress-nvram-43455-sdio-rpi-3b-plus
$(Package/cypress-nvram-default)
TITLE:=CYW43455 NVRAM for Raspberry Pi 3B+
- DEPENDS:=@TARGET_brcm2708
+ DEPENDS:=@TARGET_bcm27xx
endef
define Package/cypress-nvram-43455-sdio-rpi-3b-plus/install
@@ -82,7 +82,7 @@ $(eval $(call BuildPackage,cypress-nvram-43455-sdio-rpi-3b-plus))
define Package/cypress-nvram-43455-sdio-rpi-4b
$(Package/cypress-nvram-default)
TITLE:=CYW43455 NVRAM for Raspberry Pi 4B
- DEPENDS:=@TARGET_brcm2708
+ DEPENDS:=@TARGET_bcm27xx
endef
define Package/cypress-nvram-43455-sdio-rpi-4b/install
diff --git a/package/kernel/brcm2708-gpu-fw/Makefile b/package/kernel/bcm27xx-gpu-fw/Makefile
index fa53f48333..bbaff39cc6 100644
--- a/package/kernel/brcm2708-gpu-fw/Makefile
+++ b/package/kernel/bcm27xx-gpu-fw/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-PKG_NAME:=brcm2708-gpu-fw
+PKG_NAME:=bcm27xx-gpu-fw
PKG_VERSION:=2020-01-30
PKG_RELEASE:=63bdbe0ea609a69f5c0a2212d608ef3d9915a7ad
@@ -133,16 +133,16 @@ define Download/start4x_elf
endef
$(eval $(call Download,start4x_elf))
-define Package/brcm2708-gpu-fw
+define Package/bcm27xx-gpu-fw
SECTION:=boot
CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_brcm2708
- TITLE:=brcm2708-gpu-fw
- DEFAULT:=y if TARGET_brcm2708
+ DEPENDS:=@TARGET_bcm27xx
+ TITLE:=bcm27xx-gpu-fw
+ DEFAULT:=y if TARGET_bcm27xx
endef
-define Package/brcm2708-gpu-fw/description
- GPU and kernel boot firmware for brcm2708.
+define Package/bcm27xx-gpu-fw/description
+ GPU and kernel boot firmware for bcm27xx.
endef
define Build/Prepare
@@ -168,7 +168,7 @@ define Build/Compile
true
endef
-define Package/brcm2708-gpu-fw/install
+define Package/bcm27xx-gpu-fw/install
true
endef
@@ -189,4 +189,4 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/fixup4x.dat $(KERNEL_BUILD_DIR)
endef
-$(eval $(call BuildPackage,brcm2708-gpu-fw))
+$(eval $(call BuildPackage,bcm27xx-gpu-fw))
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 7aa97a8d9b..4fcd03ae85 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -125,7 +125,7 @@ $(eval $(call KernelPackage,mii))
define KernelPackage/mdio-gpio
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:= Supports GPIO lib-based MDIO busses
- DEPENDS:=+kmod-libphy @GPIO_SUPPORT +(TARGET_armvirt||TARGET_brcm2708_bcm2708||TARGET_samsung||TARGET_tegra):kmod-of-mdio
+ DEPENDS:=+kmod-libphy @GPIO_SUPPORT +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_samsung||TARGET_tegra):kmod-of-mdio
KCONFIG:= \
CONFIG_MDIO_BITBANG \
CONFIG_MDIO_GPIO
@@ -320,7 +320,7 @@ $(eval $(call KernelPackage,switch-rtl8306))
define KernelPackage/switch-rtl8366-smi
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Realtek RTL8366 SMI switch interface support
- DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +(TARGET_armvirt||TARGET_brcm2708_bcm2708||TARGET_samsung||TARGET_tegra):kmod-of-mdio
+ DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_samsung||TARGET_tegra):kmod-of-mdio
KCONFIG:=CONFIG_RTL8366_SMI
FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi)
diff --git a/package/kernel/mac80211/broadcom.mk b/package/kernel/mac80211/broadcom.mk
index c725c4924f..41320bcc12 100644
--- a/package/kernel/mac80211/broadcom.mk
+++ b/package/kernel/mac80211/broadcom.mk
@@ -449,7 +449,7 @@ define KernelPackage/brcmfmac/config
config BRCMFMAC_SDIO
bool "Enable SDIO bus interface support"
- default y if TARGET_brcm2708
+ default y if TARGET_bcm27xx
default y if TARGET_sunxi
default n
help
diff --git a/package/utils/brcm2708-userland/Makefile b/package/utils/bcm27xx-userland/Makefile
index 7fea952974..718e853993 100644
--- a/package/utils/brcm2708-userland/Makefile
+++ b/package/utils/bcm27xx-userland/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=brcm2708-userland
+PKG_NAME:=bcm27xx-userland
PKG_VERSION:=42ec119e03eb8dffc7c83e2ac0e665e333abbef6
PKG_RELEASE:=1
@@ -34,19 +34,19 @@ include $(INCLUDE_DIR)/cmake.mk
TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
-define Package/brcm2708-userland
+define Package/bcm27xx-userland
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@TARGET_brcm2708
- TITLE:=BCM2708 userland tools
- DEFAULT:=y if TARGET_brcm2708
+ DEPENDS:=@TARGET_bcm27xx
+ TITLE:=BCM27xx userland tools
+ DEFAULT:=y if TARGET_bcm27xx
endef
-define Package/brcm2708-userland/description
- BCM2708 userland tools including vcgencmd and tvservice.
+define Package/bcm27xx-userland/description
+ BCM27xx userland tools including vcgencmd and tvservice.
endef
-define Package/brcm2708-userland/install
+define Package/bcm27xx-userland/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtparam $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtoverlay $(1)/usr/bin
@@ -61,4 +61,4 @@ define Package/brcm2708-userland/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ $(1)/usr/
endef
-$(eval $(call BuildPackage,brcm2708-userland))
+$(eval $(call BuildPackage,bcm27xx-userland))
diff --git a/package/utils/brcm2708-userland/patches/001-interface-vcms_host-cmake-fixes.patch b/package/utils/bcm27xx-userland/patches/001-interface-vcms_host-cmake-fixes.patch
index cb73512af9..cb73512af9 100644
--- a/package/utils/brcm2708-userland/patches/001-interface-vcms_host-cmake-fixes.patch
+++ b/package/utils/bcm27xx-userland/patches/001-interface-vcms_host-cmake-fixes.patch