aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4d181245a6..a7f1a76e11 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -942,6 +942,19 @@ define Device/engenius_eap300-v2
endef
TARGET_DEVICES += engenius_eap300-v2
+define Device/engenius_ecb1200
+ SOC := qca9557
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := ECB1200
+ DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
+ IMAGE_SIZE := 15680k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
+ senao-header -r 0x101 -p 0x6e -t 2
+endef
+TARGET_DEVICES += engenius_ecb1200
+
define Device/engenius_ecb1750
SOC := qca9558
DEVICE_VENDOR := EnGenius