aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index d056ab6783..577ae98624 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -69,6 +69,15 @@ define Device/ubnt-wa
UBNT_VERSION := 8.5.0
endef
+define Device/ubnt-xc
+ $(Device/ubnt)
+ IMAGE_SIZE := 15744k
+ UBNT_BOARD := XC
+ UBNT_CHIP := qca955x
+ UBNT_TYPE := XC
+ UBNT_VERSION := 8.5.0
+endef
+
define Device/ubnt-xm
$(Device/ubnt)
DEVICE_VARIANT := XM
@@ -243,6 +252,15 @@ define Device/ubnt_picostation-m
endef
TARGET_DEVICES += ubnt_picostation-m
+define Device/ubnt_powerbeam-5ac-500
+ $(Device/ubnt-xc)
+ SOC := qca9558
+ DEVICE_MODEL := PowerBeam 5AC
+ DEVICE_VARIANT := 500
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += ubnt_powerbeam-5ac-500
+
define Device/ubnt_powerbeam-5ac-gen2
$(Device/ubnt-wa)
DEVICE_MODEL := PowerBeam 5AC