aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index a746bcfb8e..f358d44064 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -453,6 +453,29 @@ define Device/buffalo_wzr-hp-ag300h
endef
TARGET_DEVICES += buffalo_wzr-hp-ag300h
+define Device/buffalo_wzr-hp-g300nh
+ $(Device/buffalo_common)
+ SOC := ar9132
+ BUFFALO_PRODUCT := WZR-HP-G300NH
+ BUFFALO_HWVER := 1
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-gpio-nxp-74hc153
+ BLOCKSIZE := 128k
+ IMAGE_SIZE := 32128k
+ SUPPORTED_DEVICES += wzr-hp-g300nh
+endef
+
+define Device/buffalo_wzr-hp-g300nh-rb
+ $(Device/buffalo_wzr-hp-g300nh)
+ DEVICE_MODEL := WZR-HP-G300NH (RTL8366RB switch)
+endef
+TARGET_DEVICES += buffalo_wzr-hp-g300nh-rb
+
+define Device/buffalo_wzr-hp-g300nh-s
+ $(Device/buffalo_wzr-hp-g300nh)
+ DEVICE_MODEL := WZR-HP-G300NH (RTL8366S switch)
+endef
+TARGET_DEVICES += buffalo_wzr-hp-g300nh-s
+
define Device/buffalo_wzr-hp-g302h-a1a0
$(Device/buffalo_common)
SOC := ar7242