aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/dts/qca9550_airtight_c-75.dts26
-rw-r--r--target/linux/ath79/image/generic.mk3
2 files changed, 23 insertions, 6 deletions
diff --git a/target/linux/ath79/dts/qca9550_airtight_c-75.dts b/target/linux/ath79/dts/qca9550_airtight_c-75.dts
index 566aa6aef6..1bdbc86156 100644
--- a/target/linux/ath79/dts/qca9550_airtight_c-75.dts
+++ b/target/linux/ath79/dts/qca9550_airtight_c-75.dts
@@ -41,6 +41,23 @@
linux,default-trigger = "phy1tpt";
};
};
+
+ virtual_flash {
+ compatible = "mtd-concat";
+ devices = <&concat0 &concat1>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "firmware";
+ reg = <0x0 0x1f90000>;
+ compatible = "denx,uimage";
+ };
+ };
+ };
};
&eth0 {
@@ -118,10 +135,9 @@
read-only;
};
- partition@60000 {
- label = "firmware";
+ concat0: partition@60000 {
+ label = "reserved1";
reg = <0x060000 0xf90000>;
- compatible = "denx,uimage";
};
art: partition@ff0000 {
@@ -142,8 +158,8 @@
#address-cells = <1>;
#size-cells = <1>;
- partition@0 {
- label = "opt";
+ concat1: partition@0 {
+ label = "reserved2";
reg = <0x0 0x1000000>;
};
};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index baaea00c30..4d181245a6 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -246,7 +246,8 @@ define Device/airtight_c-75
DEVICE_ALT1_VENDOR := WatchGuard
DEVICE_ALT1_MODEL := AP320
DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct kmod-usb2
- IMAGE_SIZE := 15936k
+ IMAGE_SIZE := 32320k
+ KERNEL_SIZE := 15936k
endef
TARGET_DEVICES += airtight_c-75