aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/dts/ar9330_openmesh_om2p-v2.dts8
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds1
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ath79/image/generic.mk9
4 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9330_openmesh_om2p-v2.dts b/target/linux/ath79/dts/ar9330_openmesh_om2p-v2.dts
new file mode 100644
index 0000000000..659a1c71d9
--- /dev/null
+++ b/target/linux/ath79/dts/ar9330_openmesh_om2p-v2.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9330_openmesh_om2p.dtsi"
+
+/ {
+ compatible = "openmesh,om2p-v2", "qca,ar9330";
+ model = "OpenMesh OM2P v2";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index b651432dca..8f0e2f87a7 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -145,6 +145,7 @@ comfast,cf-e560ac)
ucidef_set_led_switch "lan4" "LAN4" "blue:lan4" "switch0" "0x10"
;;
comfast,cf-ew72|\
+openmesh,om2p-v2|\
openmesh,om2p-hs-v1|\
openmesh,om2p-hs-v2|\
openmesh,om2p-hs-v3|\
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index ea3d9d6d84..2c907ac101 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -50,6 +50,7 @@ platform_do_upgrade() {
jjplus,ja76pf2)
redboot_fis_do_upgrade "$1" linux
;;
+ openmesh,om2p-v2|\
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
openmesh,om2p-hs-v2|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 6f21db78d2..acb456ba44 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1568,6 +1568,15 @@ define Device/openmesh_om2p-common
openmesh-image ce_type=OM2P | append-metadata
endef
+define Device/openmesh_om2p-v2
+ $(Device/openmesh_om2p-common)
+ SOC := ar9330
+ DEVICE_MODEL := OM2P
+ DEVICE_VARIANT := v2
+ SUPPORTED_DEVICES += om2pv2
+endef
+TARGET_DEVICES += openmesh_om2p-v2
+
define Device/openmesh_om2p-v4
$(Device/openmesh_om2p-common)
SOC := qca9533