aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx/legacy
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm47xx/legacy')
-rw-r--r--target/linux/bcm47xx/legacy/config-default8
-rw-r--r--target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk20
-rw-r--r--target/linux/bcm47xx/legacy/profiles/101-Broadcom-wl.mk20
-rw-r--r--target/linux/bcm47xx/legacy/target.mk10
4 files changed, 58 insertions, 0 deletions
diff --git a/target/linux/bcm47xx/legacy/config-default b/target/linux/bcm47xx/legacy/config-default
new file mode 100644
index 0000000000..8a52e475c7
--- /dev/null
+++ b/target/linux/bcm47xx/legacy/config-default
@@ -0,0 +1,8 @@
+CONFIG_B44=y
+CONFIG_B44_PCI=y
+CONFIG_B44_PCICORE_AUTOSELECT=y
+CONFIG_B44_PCI_AUTOSELECT=y
+# CONFIG_BCM47XX_BCMA is not set
+# CONFIG_BCMA is not set
+# CONFIG_MTD_NAND is not set
+# CONFIG_SSB_DRIVER_GIGE is not set
diff --git a/target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk b/target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..50d777010b
--- /dev/null
+++ b/target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+
diff --git a/target/linux/bcm47xx/legacy/profiles/101-Broadcom-wl.mk b/target/linux/bcm47xx/legacy/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000000..6a4c5b0394
--- /dev/null
+++ b/target/linux/bcm47xx/legacy/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-brcm-wl-mini wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/bcm47xx/legacy/target.mk b/target/linux/bcm47xx/legacy/target.mk
new file mode 100644
index 0000000000..fca6128558
--- /dev/null
+++ b/target/linux/bcm47xx/legacy/target.mk
@@ -0,0 +1,10 @@
+FEATURES += low_mem pcmcia small_flash
+BOARDNAME:=Legacy (BMIPS3300)
+
+DEFAULT_PACKAGES += wpad-mini
+
+define Target/Description
+ Build firmware for Broadcom BCM47xx and BCM53xx devices with
+ BMIPS3300 CPU except for BCM4705 SoC.
+ Supported SoCs: BCM5352E, BCM5354, BCM5365?, BCM4712, BCM4704.
+endef