aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/Makefile')
-rw-r--r--target/linux/bmips/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/bmips/Makefile b/target/linux/bmips/Makefile
new file mode 100644
index 0000000000..0adc8cd97e
--- /dev/null
+++ b/target/linux/bmips/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+CPU_TYPE:=mips32
+BOARD:=bmips
+BOARDNAME:=Broadcom BMIPS
+SUBTARGETS:=generic nand
+FEATURES:=gpio source-only squashfs usb
+
+KERNEL_PATCHVER:=5.10
+
+define Target/Description
+ Build firmware images for BCM33xx cable modem chips,
+ BCM63xx DSL chips and BCM7xxx set-top box chips.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-gpio-button-hotplug
+
+$(eval $(call BuildTarget))