aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch')
-rw-r--r--target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch b/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
index dd8a1b445d..b01507e653 100644
--- a/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
+++ b/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
@@ -39,13 +39,13 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
+++ b/Makefile
@@ -416,7 +416,8 @@ HOSTCXX = g++
endif
-
+
export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
- -O2 -fomit-frame-pointer -std=gnu89
+ -O2 -fomit-frame-pointer -std=gnu89 \
+ -Wdeclaration-after-statement
export KBUILD_USERLDFLAGS :=
-
+
KBUILD_HOSTCFLAGS := $(KBUILD_USERCFLAGS) $(HOST_LFS_CFLAGS) $(HOSTCFLAGS)
--- a/arch/arm64/kernel/vdso32/Makefile
+++ b/arch/arm64/kernel/vdso32/Makefile
@@ -61,13 +61,13 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
+++ b/scripts/mod/modpost.c
@@ -844,8 +844,10 @@ static int match(const char *sym, const
{
- const char *p;
- while (*pat) {
+ const char *p;
+ while (*pat) {
+ const char *endp;
+
- p = *pat++;
+ p = *pat++;
- const char *endp = p + strlen(p) - 1;
+ endp = p + strlen(p) - 1;
-
- /* "*foo*" */
- if (*p == '*' && *endp == '*') {
+
+ /* "*foo*" */
+ if (*p == '*' && *endp == '*') {