aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.18/259-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-3.18/259-regmap_dynamic.patch19
1 files changed, 13 insertions, 6 deletions
diff --git a/target/linux/generic/patches-3.18/259-regmap_dynamic.patch b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
index b1d4ad2772..5e422ebd48 100644
--- a/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
@@ -1,16 +1,19 @@
--- a/drivers/base/regmap/Kconfig
+++ b/drivers/base/regmap/Kconfig
-@@ -3,26 +3,31 @@
+@@ -3,9 +3,8 @@
# subsystems should select the appropriate symbols.
config REGMAP
- default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_MMIO || REGMAP_IRQ)
- select LZO_COMPRESS
- select LZO_DECOMPRESS
select IRQ_DOMAIN if REGMAP_IRQ
- bool
+ tristate "Regmap"
+ config REGCACHE_COMPRESSED
+ select LZO_COMPRESS
+@@ -13,19 +12,25 @@ config REGCACHE_COMPRESSED
+ bool
+
config REGMAP_I2C
- tristate
+ tristate "Regmap I2C"
@@ -50,14 +53,18 @@
/* Unspecified -> 0 -> Backwards compatible default */
--- a/drivers/base/regmap/Makefile
+++ b/drivers/base/regmap/Makefile
-@@ -1,6 +1,8 @@
+@@ -1,7 +1,11 @@
-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
--obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
+-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-flat.o
+-obj-$(CONFIG_REGCACHE_COMPRESSED) += regcache-lzo.o
-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
-+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
++regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-flat.o
+ifdef CONFIG_DEBUG_FS
+regmap-core-objs += regmap-debugfs.o
+endif
++ifdef CONFIG_REGCACHE_COMPRESSED
++regmap-core-objs += regcache-lzo.o
++endif
+obj-$(CONFIG_REGMAP) += regmap-core.o
obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o