aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.9/259-regmap_dynamic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.9/259-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-4.9/259-regmap_dynamic.patch19
1 files changed, 11 insertions, 8 deletions
diff --git a/target/linux/generic/patches-4.9/259-regmap_dynamic.patch b/target/linux/generic/patches-4.9/259-regmap_dynamic.patch
index 48aa8083d9..8cc2361c0b 100644
--- a/target/linux/generic/patches-4.9/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-4.9/259-regmap_dynamic.patch
@@ -1,18 +1,17 @@
--- a/drivers/base/regmap/Kconfig
+++ b/drivers/base/regmap/Kconfig
-@@ -3,29 +3,35 @@
+@@ -3,9 +3,8 @@
# subsystems should select the appropriate symbols.
config REGMAP
- default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_AC97 || REGMAP_MMIO || REGMAP_IRQ)
- select LZO_COMPRESS
- select LZO_DECOMPRESS
select IRQ_DOMAIN if REGMAP_IRQ
- bool
+ tristate "Regmap"
- config REGMAP_AC97
-+ select REGMAP
+ config REGCACHE_COMPRESSED
+ select LZO_COMPRESS
+@@ -16,19 +15,25 @@ config REGMAP_AC97
tristate
config REGMAP_I2C
@@ -54,17 +53,21 @@
/* Unspecified -> 0 -> Backwards compatible default */
--- a/drivers/base/regmap/Makefile
+++ b/drivers/base/regmap/Makefile
-@@ -1,9 +1,11 @@
+@@ -1,10 +1,14 @@
# For include/trace/define_trace.h to include trace.h
CFLAGS_regmap.o := -I$(src)
-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
--obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
+-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-flat.o
+-obj-$(CONFIG_REGCACHE_COMPRESSED) += regcache-lzo.o
-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
-+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
++regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-flat.o
+ifdef CONFIG_DEBUG_FS
+regmap-core-objs += regmap-debugfs.o
+endif
++ifdef CONFIG_REGCACHE_COMPRESSED
++regmap-core-objs += regcache-lzo.o
++endif
+obj-$(CONFIG_REGMAP) += regmap-core.o
obj-$(CONFIG_REGMAP_AC97) += regmap-ac97.o
obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o