aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape')
-rw-r--r--target/linux/layerscape/base-files/lib/upgrade/platform.sh13
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk52
2 files changed, 61 insertions, 4 deletions
diff --git a/target/linux/layerscape/base-files/lib/upgrade/platform.sh b/target/linux/layerscape/base-files/lib/upgrade/platform.sh
index f9b1e57a43..857be5a744 100644
--- a/target/linux/layerscape/base-files/lib/upgrade/platform.sh
+++ b/target/linux/layerscape/base-files/lib/upgrade/platform.sh
@@ -74,7 +74,8 @@ platform_copy_config() {
fsl,ls1043a-rdb-sdboot | \
fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb-sdboot | \
- fsl,ls1088a-rdb-sdboot)
+ fsl,ls1088a-rdb-sdboot | \
+ fsl,lx2160a-rdb-sdboot)
platform_copy_config_sdboot
;;
esac
@@ -102,7 +103,9 @@ platform_check_image() {
fsl,ls1046a-rdb-sdboot | \
fsl,ls1088a-rdb | \
fsl,ls1088a-rdb-sdboot | \
- fsl,ls2088a-rdb)
+ fsl,ls2088a-rdb | \
+ fsl,lx2160a-rdb | \
+ fsl,lx2160a-rdb-sdboot)
return 0
;;
*)
@@ -131,7 +134,8 @@ platform_do_upgrade() {
fsl,ls1046a-frwy | \
fsl,ls1046a-rdb | \
fsl,ls1088a-rdb | \
- fsl,ls2088a-rdb)
+ fsl,ls2088a-rdb | \
+ fsl,lx2160a-rdb)
PART_NAME=firmware
default_do_upgrade "$1"
;;
@@ -141,7 +145,8 @@ platform_do_upgrade() {
fsl,ls1043a-rdb-sdboot | \
fsl,ls1046a-frwy-sdboot | \
fsl,ls1046a-rdb-sdboot | \
- fsl,ls1088a-rdb-sdboot)
+ fsl,ls1088a-rdb-sdboot | \
+ fsl,lx2160a-rdb-sdboot)
platform_do_upgrade_sdboot "$1"
return 0
;;
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index c037061aa2..89c81e5cb4 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -323,6 +323,58 @@ define Device/fsl_ls2088a-rdb
endef
TARGET_DEVICES += fsl_ls2088a-rdb
+define Device/fsl_lx2160a-rdb
+ DEVICE_VENDOR := NXP
+ DEVICE_MODEL := LX2160A-RDB
+ DEVICE_VARIANT := Rev2.0 silicon
+ DEVICE_PACKAGES += \
+ layerscape-mc \
+ layerscape-dpl \
+ layerscape-ddr-phy \
+ tfa-lx2160a-rdb \
+ restool
+ IMAGE/firmware.bin := \
+ ls-clean | \
+ ls-append $(1)-bl2.pbl | pad-to 1M | \
+ ls-append $(1)-fip.bin | pad-to 5M | \
+ ls-append $(1)-uboot-env.bin | pad-to 8M | \
+ ls-append $(1)-fip_ddr_all.bin | pad-to 10M | \
+ ls-append $(1)-mc.itb | pad-to 13M | \
+ ls-append $(1)-dpl.dtb | pad-to 14M | \
+ ls-append $(1)-dpc.dtb | pad-to 15M | \
+ ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-rootfs | pad-rootfs | check-size
+endef
+TARGET_DEVICES += fsl_lx2160a-rdb
+
+define Device/fsl_lx2160a-rdb-sdboot
+ $(Device/fsl-sdboot)
+ DEVICE_VENDOR := NXP
+ DEVICE_MODEL := LX2160A-RDB
+ DEVICE_VARIANT := Rev2.0 silicon SD Card Boot
+ DEVICE_PACKAGES += \
+ layerscape-mc \
+ layerscape-dpl \
+ layerscape-ddr-phy \
+ tfa-lx2160a-rdb-sdboot \
+ restool
+ DEVICE_DTS := freescale/fsl-lx2160a-rdb
+ IMAGE/sdcard.img.gz := \
+ ls-clean | \
+ ls-append-sdhead $(1) | pad-to 4K | \
+ ls-append $(1)-bl2.pbl | pad-to 1M | \
+ ls-append $(1)-fip.bin | pad-to 5M | \
+ ls-append $(1)-uboot-env.bin | pad-to 8M | \
+ ls-append fsl_lx2160a-rdb-fip_ddr_all.bin | pad-to 10M | \
+ ls-append fsl_lx2160a-rdb-mc.itb | pad-to 13M | \
+ ls-append fsl_lx2160a-rdb-dpl.dtb | pad-to 14M | \
+ ls-append fsl_lx2160a-rdb-dpc.dtb | pad-to 16M | \
+ ls-append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+ append-rootfs | pad-to $(LS_SD_IMAGE_SIZE)M | gzip
+endef
+TARGET_DEVICES += fsl_lx2160a-rdb-sdboot
+
define Device/traverse_ls1043
DEVICE_VENDOR := Traverse
DEVICE_MODEL := LS1043 Boards