aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mxs/image')
-rw-r--r--target/linux/mxs/image/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
new file mode 100644
index 0000000000..b9102375d6
--- /dev/null
+++ b/target/linux/mxs/image/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel/olinuxino-bootlet
+ cat $(LINUX_DIR)/arch/arm/boot/zImage $(LINUX_DIR)/arch/arm/boot/dts/imx23-olinuxino.dtb > $(STAGING_DIR)/zImage_dtb
+ (cd $(STAGING_DIR); \
+ $(STAGING_DIR)/../host/bin/elftosb -z -c ./linux_prebuilt.db -o linux.sb; \
+ dd if=/dev/zero of=sd_mmc_bootstream.raw bs=512 count=4; \
+ dd if=linux.sb of=$(BIN_DIR)/openwrt-imx23-sbImage ibs=512 seek=4; \
+ )
+endef
+
+define Image/BuildKernel/olinuxino-uboot
+ mkimage -A arm -O linux -T kernel -C none \
+ -a 0x42000000 -e 0x42000000 \
+ -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux $(KDIR)/uImage
+ cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+define Image/BuildKernel
+
+ ifeq ($(CONFIG_PACKAGE_imx-bootlets),y)
+ $(call Image/BuildKernel/olinuxino-bootlet)
+ endif
+
+ ifeq ($(CONFIG_PACKAGE_uboot-imx23-mx23_olinuxino),y)
+ $(call Image/BuildKernel/olinuxino-uboot)
+ endif
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))
+