aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/octeon/image')
-rw-r--r--target/linux/octeon/image/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 7851e4a99c..b91c262447 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -7,11 +7,17 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Build/append-dtb-to-elf
+ $(TARGET_CROSS)objcopy --update-section .appended_dtb=$(KDIR)/image-$(DEVICE_DTS).dtb $@
+endef
+
define Build/strip-kernel
# Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
$(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
endef
+DTS_DIR := $(DTS_DIR)/cavium-octeon
+
define Device/Default
PROFILES = Default $$(DEVICE_NAME)
KERNEL_NAME := vmlinux.elf
@@ -48,6 +54,17 @@ define Device/ubnt_edgerouter
endef
TARGET_DEVICES += ubnt_edgerouter
+define Device/ubnt_edgerouter-4
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := EdgeRouter 4
+ DEVICE_DTS := cn7130_ubnt_edgerouter-4
+ DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-leds-gpio kmod-of-mdio kmod-sfp kmod-usb3 kmod-usb-dwc3 kmod-usb-storage-uas
+ KERNEL := kernel-bin | patch-cmdline | append-dtb-to-elf
+ KERNEL_DEPENDS := $$(wildcard $(DTS_DIR)/$(DEVICE_DTS).dts)
+ CMDLINE := root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
+endef
+TARGET_DEVICES += ubnt_edgerouter-4
+
ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
define Device/ubnt_edgerouter-lite
DEVICE_VENDOR := Ubiquiti