aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 848a0785fb..d6423f81d9 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -307,6 +307,18 @@ define Device/elecom_wrc-2533gst
endef
TARGET_DEVICES += elecom_wrc-2533gst
+define Device/elecom_wrc-2533gst2
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 24576k
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-2533GST2
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
+ elecom-gst-factory WRC-2533GST2 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+endef
+TARGET_DEVICES += elecom_wrc-2533gst2
+
define Device/firefly_firewrt
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Firefly