aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk23
1 files changed, 13 insertions, 10 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6b2e68b03b..806286b0bb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -794,27 +794,30 @@ define Device/tplink_re650-v1
endef
TARGET_DEVICES += tplink_re650-v1
-define Device/ubiquiti_edgerouterx
+define Device/ubnt_edgerouter_common
+ DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
FILESYSTEMS := squashfs
KERNEL_SIZE := 3145728
KERNEL_INITRAMFS := $$(KERNEL) | \
ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_VENDOR := Ubiquiti
+endef
+
+define Device/ubnt_edgerouter-x
+ $(Device/ubnt_edgerouter_common)
DEVICE_MODEL := EdgeRouter X
- SUPPORTED_DEVICES += ubnt-erx
+ SUPPORTED_DEVICES += ubnt-erx ubiquiti,edgerouterx
endef
-TARGET_DEVICES += ubiquiti_edgerouterx
+TARGET_DEVICES += ubnt_edgerouter-x
-define Device/ubiquiti_edgerouterx-sfp
- $(Device/ubiquiti_edgerouterx)
- DEVICE_VENDOR := Ubiquiti
- DEVICE_MODEL := EdgeRouter X-SFP
+define Device/ubnt_edgerouter-x-sfp
+ $(Device/ubnt_edgerouter_common)
+ DEVICE_MODEL := EdgeRouter X SFP
DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x
- SUPPORTED_DEVICES += ubnt-erx-sfp
+ SUPPORTED_DEVICES += ubnt-erx-sfp ubiquiti,edgerouterx-sfp
endef
-TARGET_DEVICES += ubiquiti_edgerouterx-sfp
+TARGET_DEVICES += ubnt_edgerouter-x-sfp
define Device/ubnt_unifi-nanohd
DEVICE_VENDOR := Ubiquiti