aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/sevenlinks.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/sevenlinks.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/sevenlinks.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/target/linux/ramips/rt305x/profiles/sevenlinks.mk b/target/linux/ramips/rt305x/profiles/sevenlinks.mk
index e1a86652dd..6ddc3832d4 100644
--- a/target/linux/ramips/rt305x/profiles/sevenlinks.mk
+++ b/target/linux/ramips/rt305x/profiles/sevenlinks.mk
@@ -5,16 +5,14 @@
# See /LICENSE for more information.
#
-define Profile/PX4885
+define Profile/PX-4885
NAME:=7Links PX-4885
PACKAGES:=\
kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci \
kmod-ledtrig-usbdev kmod-leds-gpio
endef
-define Profile/PX4885/Description
+define Profile/PX-4885/Description
Package set for 7Links PX-4885 wireless router.
endef
-
-$(eval $(call Profile,PX4885))
-
+$(eval $(call Profile,PX-4885))
id='n126' href='#n126'>126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237
/dts-v1/;

/include/ "vr9.dtsi"

/ {
	model = "ARV7519RW22 - Orange Livebox 2.1";

	chosen {
		bootargs = "console=ttyLTQ0,115200 init=/etc/preinit";

		leds {
			boot = &power_green;
			failsafe = &power_green;
			running = &power_green;

			internet = &internet_green;
		};
	};

	memory@0 {
		reg = <0x0 0x8000000>;
	};

	fpi@10000000 {
		localbus@0 {
			nor-boot@0 {
				compatible = "lantiq,nor";
				bank-width = <2>;
				reg = <0 0x0 0x2000000>;
				#address-cells = <1>;
				#size-cells = <1>;

				partition@0 {
					label = "uboot";
					reg = <0x0 0x60000>;
					read-only;
				};

				partition@60000 {
					label = "uboot-env";
					reg = <0x60000 0x20000>;
					read-only;
				};

				partition@80000 {
					label = "firmware";
					reg = <0x80000 0x1f00000>;
				};

				boardconfig: partition@1f80000 {
					label = "boardconfig";
					reg = <0x1f80000 0x80000>;
					read-only;
				};
			};
		};

		gpio: pinmux@E100B10 {
			pinctrl-names = "default";
			pinctrl-0 = <&state_default>;

			state_default: pinmux {
				mdio {
					lantiq,groups = "mdio";
					lantiq,function = "mdio";
				};
				pcie-rst {
					lantiq,pins = "io21";
					lantiq,pull = <0>;
					lantiq,output = <1>;
				};
			};
		};

		eth@E108000 {
			#address-cells = <1>;
			#size-cells = <0>;
			compatible = "lantiq,xrx200-net";
			reg = <	0xE108000 0x3000 /* switch */
				0xE10B100 0x70 /* mdio */
				0xE10B1D8 0x30 /* mii */
				0xE10B308 0x30 /* pmac */
			>;
			interrupt-parent = <&icu0>;
			interrupts = <73 72>;

			lan: interface@0 {
				compatible = "lantiq,xrx200-pdi";
				#address-cells = <1>;
				#size-cells = <0>;
				reg = <0>;
				mtd-mac-address = <&boardconfig 0x16>;
				lantiq,switch;

				ethernet@0 {
					compatible = "lantiq,xrx200-pdi-port";
					reg = <0>;
					phy-mode = "rgmii";
					phy-handle = <&phy0>;
				};
				ethernet@1 {
					compatible = "lantiq,xrx200-pdi-port";
					reg = <4>;
					phy-mode = "mii";
					phy-handle = <&phy13>;
				};
				ethernet@2 {
					compatible = "lantiq,xrx200-pdi-port";
					reg = <5>;
					phy-mode = "mii";
					phy-handle = <&phy14>;
				};
				ethernet@3 {
					compatible = "lantiq,xrx200-pdi-port";
					reg = <2>;
					phy-mode = "mii";
					phy-handle = <&phy11>;
				};
				ethernet@4 {
					compatible = "lantiq,xrx200-pdi-port";
					reg = <3>;
					phy-mode = "mii";
					phy-handle = <&phy12>;
				};
			};

			mdio@0 {
				#address-cells = <1>;
				#size-cells = <0>;
				compatible = "lantiq,xrx200-mdio";
				phy0: ethernet-phy@0 {
					reg = <0x0>;
					compatible = "lantiq,phy11g", "ethernet-phy-ieee802.3-c22";
				};
				phy11: ethernet-phy@11 {
					reg = <0x11>;
					compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
				};
				phy12: ethernet-phy@12 {
					reg = <0x12>;
					compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
				};
				phy13: ethernet-phy@13 {
					reg = <0x13>;
					compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
				};
				phy14: ethernet-phy@14 {
					reg = <0x14>;
					compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
				};
			};
		};

		ifxhcd@E101000 {
			status = "okay";
			gpios = <&gpio 32 0>;
		};

		ifxhcd@E106000 {
			status = "okay";
			gpios = <&gpio 32 0>;
		};

		pcie@d900000 {
			status = "disabled";
		};

		pci@E105400 {
			status = "disabled";
			compatible = "lantiq,pci-xway";
		};
	};

	gphy-xrx200 {
		compatible = "lantiq,phy-xrx200";
		firmware1 = "lantiq/vr9_phy22f_a1x.bin";	/*VR9 1.1*/
		firmware2 = "lantiq/vr9_phy22f_a2x.bin";	/*VR9 1.2*/
		phys = [ 00 01 ];
	};

	gpio-keys-polled {
		compatible = "gpio-keys-polled";
		#address-cells = <1>;
		#size-cells = <0>;
		poll-interval = <100>;

		reset {
			label = "reset";
			gpios = <&gpio 6 1>;
			linux,code = <0x198>;
		};
		rfkill {
			label = "rfkill";
			gpios = <&gpio 33 1>;
			linux,code = <0xf7>;
		};
		wps {
			label = "wps";
			gpios = <&gpio 37 1>;
			linux,code = <0x211>;
		};
	};

	gpio-leds {
		compatible = "gpio-leds";

		lan_green {
			label = "arv7519rw22:green:lan";
			gpios = <&gpio 2 1>;
		};
		internet_red {
			label = "arv7519rw22:red:internet";
			gpios = <&gpio 10 1>;
		};
		power_green: power_green {
			label = "arv7519rw22:green:power";
			gpios = <&gpio 14 1>;
			default-state = "keep";
		};
		alarm_blue {
			label = "arv7519rw22:blue:alarm";
			gpios = <&gpio 15 1>;
		};
		internet_orange {
			label = "arv7519rw22:orange:internet";
			gpios = <&gpio 19 1>;
		};
		internet_green: internet_green {
			label = "arv7519rw22:green:internet";
			gpios = <&gpio 28 1>;
		};
		voice_green {
			label = "arv7519rw22:green:voice";
			gpios = <&gpio 29 1>;
		};
	};
};