aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/realtek/dts/rtl8380_netgear_gigabit.dtsi58
-rw-r--r--target/linux/realtek/dts/rtl8380_netgear_gigabit_1xx.dtsi61
-rw-r--r--target/linux/realtek/dts/rtl8380_netgear_gigabit_3xx.dtsi61
-rw-r--r--target/linux/realtek/dts/rtl8380_netgear_gs108t-v3.dts2
-rw-r--r--target/linux/realtek/dts/rtl8380_netgear_gs110tpp-v1.dts2
-rw-r--r--target/linux/realtek/dts/rtl8380_netgear_gs308t-v1.dts8
-rw-r--r--target/linux/realtek/dts/rtl8380_netgear_gs310tp-v1.dts21
-rw-r--r--target/linux/realtek/image/Makefile17
9 files changed, 173 insertions, 60 deletions
diff --git a/target/linux/realtek/base-files/etc/board.d/02_network b/target/linux/realtek/base-files/etc/board.d/02_network
index 1e199db589..c1dd230bb8 100644
--- a/target/linux/realtek/base-files/etc/board.d/02_network
+++ b/target/linux/realtek/base-files/etc/board.d/02_network
@@ -51,6 +51,9 @@ case $board in
netgear,gs110tpp-v1)
ucidef_set_poe 130 "$lan_list"
;;
+netgear,gs310tp-v1)
+ ucidef_set_poe 55 "$lan_list"
+ ;;
zyxel,gs1900-10hp)
ucidef_set_poe 77 "$lan_list"
;;
diff --git a/target/linux/realtek/dts/rtl8380_netgear_gigabit.dtsi b/target/linux/realtek/dts/rtl8380_netgear_gigabit.dtsi
index 0d34ca5dc2..8ba66d6023 100644
--- a/target/linux/realtek/dts/rtl8380_netgear_gigabit.dtsi
+++ b/target/linux/realtek/dts/rtl8380_netgear_gigabit.dtsi
@@ -33,64 +33,6 @@
indirect-access-bus-id = <0>;
};
-&spi0 {
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <50000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0000000 0x00e0000>;
- read-only;
- };
-
- partition@e0000 {
- label = "u-boot-env";
- reg = <0x00e0000 0x0010000>;
- read-only;
- };
-
- partition@f0000 {
- label = "u-boot-env2";
- reg = <0x00f0000 0x0010000>;
- };
-
- partition@100000 {
- label = "jffs";
- reg = <0x0100000 0x0100000>;
- read-only;
- };
-
- partition@200000 {
- label = "jffs2";
- reg = <0x0200000 0x0100000>;
- read-only;
- };
-
- partition@300000 {
- label = "firmware";
- compatible = "openwrt,uimage", "denx,uimage";
- openwrt,ih-magic = <0x4e474520>;
- reg = <0x0300000 0x0e80000>;
- };
-
- partition@1180000 {
- label = "runtime2";
- reg = <0x1180000 0x0e80000>;
- read-only;
- };
- };
- };
-};
-
&ethernet0 {
mdio: mdio-bus {
compatible = "realtek,rtl838x-mdio";
diff --git a/target/linux/realtek/dts/rtl8380_netgear_gigabit_1xx.dtsi b/target/linux/realtek/dts/rtl8380_netgear_gigabit_1xx.dtsi
new file mode 100644
index 0000000000..7eccfcb5a2
--- /dev/null
+++ b/target/linux/realtek/dts/rtl8380_netgear_gigabit_1xx.dtsi
@@ -0,0 +1,61 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+
+#include "rtl8380_netgear_gigabit.dtsi"
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0000000 0x00e0000>;
+ read-only;
+ };
+
+ partition@e0000 {
+ label = "u-boot-env";
+ reg = <0x00e0000 0x0010000>;
+ read-only;
+ };
+
+ partition@f0000 {
+ label = "u-boot-env2";
+ reg = <0x00f0000 0x0010000>;
+ };
+
+ partition@100000 {
+ label = "jffs";
+ reg = <0x0100000 0x0100000>;
+ read-only;
+ };
+
+ partition@200000 {
+ label = "jffs2";
+ reg = <0x0200000 0x0100000>;
+ read-only;
+ };
+
+ partition@300000 {
+ label = "firmware";
+ compatible = "openwrt,uimage", "denx,uimage";
+ openwrt,ih-magic = <0x4e474520>;
+ reg = <0x0300000 0x0e80000>;
+ };
+
+ partition@1180000 {
+ label = "runtime2";
+ reg = <0x1180000 0x0e80000>;
+ read-only;
+ };
+ };
+ };
+};
diff --git a/target/linux/realtek/dts/rtl8380_netgear_gigabit_3xx.dtsi b/target/linux/realtek/dts/rtl8380_netgear_gigabit_3xx.dtsi
new file mode 100644
index 0000000000..efb146a25a
--- /dev/null
+++ b/target/linux/realtek/dts/rtl8380_netgear_gigabit_3xx.dtsi
@@ -0,0 +1,61 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+
+#include "rtl8380_netgear_gigabit.dtsi"
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0000000 0x00e0000>;
+ read-only;
+ };
+
+ partition@e0000 {
+ label = "u-boot-env";
+ reg = <0x00e0000 0x0010000>;
+ read-only;
+ };
+
+ partition@f0000 {
+ label = "u-boot-env2";
+ reg = <0x00f0000 0x0010000>;
+ };
+
+ partition@100000 {
+ label = "jffs";
+ reg = <0x0100000 0x0100000>;
+ read-only;
+ };
+
+ partition@200000 {
+ label = "jffs2";
+ reg = <0x0200000 0x0100000>;
+ read-only;
+ };
+
+ partition@300000 {
+ label = "firmware";
+ compatible = "openwrt,uimage", "denx,uimage";
+ openwrt,ih-magic = <0x4e474335>;
+ reg = <0x0300000 0x0e80000>;
+ };
+
+ partition@1180000 {
+ label = "runtime2";
+ reg = <0x1180000 0x0e80000>;
+ read-only;
+ };
+ };
+ };
+};
diff --git a/target/linux/realtek/dts/rtl8380_netgear_gs108t-v3.dts b/target/linux/realtek/dts/rtl8380_netgear_gs108t-v3.dts
index 080fee6107..b701e88d1a 100644
--- a/target/linux/realtek/dts/rtl8380_netgear_gs108t-v3.dts
+++ b/target/linux/realtek/dts/rtl8380_netgear_gs108t-v3.dts
@@ -1,6 +1,6 @@
// SPDX-License-Identifier: GPL-2.0-or-later
-#include "rtl8380_netgear_gigabit.dtsi"
+#include "rtl8380_netgear_gigabit_1xx.dtsi"
/ {
compatible = "netgear,gs108t-v3", "realtek,rtl838x-soc";
diff --git a/target/linux/realtek/dts/rtl8380_netgear_gs110tpp-v1.dts b/target/linux/realtek/dts/rtl8380_netgear_gs110tpp-v1.dts
index 265cc51c30..646f4ed516 100644
--- a/target/linux/realtek/dts/rtl8380_netgear_gs110tpp-v1.dts
+++ b/target/linux/realtek/dts/rtl8380_netgear_gs110tpp-v1.dts
@@ -1,6 +1,6 @@
// SPDX-License-Identifier: GPL-2.0-or-later
-#include "rtl8380_netgear_gigabit.dtsi"
+#include "rtl8380_netgear_gigabit_1xx.dtsi"
/ {
compatible = "netgear,gs110tpp-v1", "realtek,rtl838x-soc";
diff --git a/target/linux/realtek/dts/rtl8380_netgear_gs308t-v1.dts b/target/linux/realtek/dts/rtl8380_netgear_gs308t-v1.dts
new file mode 100644
index 0000000000..016ed8beb6
--- /dev/null
+++ b/target/linux/realtek/dts/rtl8380_netgear_gs308t-v1.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+
+#include "rtl8380_netgear_gigabit_3xx.dtsi"
+
+/ {
+ compatible = "netgear,gs308t-v1", "realtek,rtl838x-soc";
+ model = "Netgear GS308T v1";
+};
diff --git a/target/linux/realtek/dts/rtl8380_netgear_gs310tp-v1.dts b/target/linux/realtek/dts/rtl8380_netgear_gs310tp-v1.dts
new file mode 100644
index 0000000000..e3f59bde69
--- /dev/null
+++ b/target/linux/realtek/dts/rtl8380_netgear_gs310tp-v1.dts
@@ -0,0 +1,21 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+
+#include "rtl8380_netgear_gigabit_3xx.dtsi"
+
+/ {
+ compatible = "netgear,gs310tp-v1", "realtek,rtl838x-soc";
+ model = "Netgear GS310TP v1";
+
+};
+
+&mdio {
+ INTERNAL_PHY(24)
+ INTERNAL_PHY(26)
+};
+
+&switch0 {
+ ports {
+ SWITCH_SFP_PORT(24, 9, rgmii-id)
+ SWITCH_SFP_PORT(26, 10, rgmii-id)
+ };
+};
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 18e5fedb9b..b889cf84d8 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -86,6 +86,23 @@ define Device/netgear_gs110tpp-v1
endef
TARGET_DEVICES += netgear_gs110tpp-v1
+define Device/netgear_gs308t-v1
+ $(Device/netgear_nge)
+ DEVICE_MODEL := GS308T
+ DEVICE_VARIANT := v1
+ UIMAGE_MAGIC := 0x4e474335
+endef
+TARGET_DEVICES += netgear_gs308t-v1
+
+define Device/netgear_gs310tp-v1
+ $(Device/netgear_nge)
+ DEVICE_MODEL := GS310TP
+ DEVICE_VARIANT := v1
+ UIMAGE_MAGIC := 0x4e474335
+ DEVICE_PACKAGES += lua-rs232
+endef
+TARGET_DEVICES += netgear_gs310tp-v1
+
define Device/zyxel_gs1900
SOC := rtl8380
IMAGE_SIZE := 6976k