From 78ca6a5578d6c7b06ca520b0aac965a1babf5417 Mon Sep 17 00:00:00 2001
From: Mathias Kresin <dev@kresin.me>
Date: Fri, 30 Nov 2018 08:57:03 +0100
Subject: ramips: merge relocate compile into build recipe

Compile the loader if the relocate-kernel image recipe is used and get
rid of the legacy build code to do so.

Signed-off-by: Mathias Kresin <dev@kresin.me>
---
 target/linux/ramips/image/Makefile  | 6 +++++-
 target/linux/ramips/image/mt7621.mk | 9 ---------
 2 files changed, 5 insertions(+), 10 deletions(-)

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 9cf64361a4..b4ff9a7492 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -74,12 +74,16 @@ define Build/loader-kernel
 endef
 
 define Build/relocate-kernel
+	rm -rf $@.relocate
+	$(CP) ../../generic/image/relocate $@.relocate
+	$(MAKE) -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
 	( \
-		dd if=$(KDIR)/loader.bin bs=32 conv=sync && \
+		dd if=$@.relocate/loader.bin bs=32 conv=sync && \
 		perl -e '@s = stat("$@"); print pack("V", @s[7])' && \
 		cat $@ \
 	) > $@.new
 	mv $@.new $@
+	rm -rf $@.relocate
 endef
 
 define MkCombineduImage
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6a04cd0e38..92bdbcf743 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -558,12 +558,3 @@ define Device/zbt-wg3526-32M
 	kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
 endef
 TARGET_DEVICES += zbt-wg3526-32M
-
-# FIXME: is this still needed?
-define Image/Prepare
-#define Build/Compile
-	rm -rf $(KDIR)/relocate
-	$(CP) ../../generic/image/relocate $(KDIR)
-	$(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
-	$(CP) $(KDIR)/relocate/loader.bin $(KDIR)/loader.bin
-endef
-- 
cgit v1.2.3