From b89accdfbc771e9936abf33dd5cfcd6882841564 Mon Sep 17 00:00:00 2001
From: Eike Ritter <git@rittere.co.uk>
Date: Sun, 14 Mar 2021 18:50:21 +0000
Subject: ppp: compile fix: unset FILTER variable in Makefile

If the environment variable FILTER is set before compilation,
compilation of the ppp-package will fail with the error message

Package ppp is missing dependencies for the following libraries:
libpcap.so.1

The reason is that the OpenWrt-patch for the Makefile only comments
out the line FILTER=y. Hence the pcap-library will be dynamically
linked if the environment variable FILTER is set elsewhere, which
causes compilation to fail. The fix consists on explicitly unsetting
the variable FILTER instead.

Signed-off-by: Eike Ritter <git@rittere.co.uk>
(cherry picked from commit 46cd0765d0c585dc0b48c8c0a3f116ef83cd580f)
---
 .../network/services/ppp/patches/610-pppd_compile_fix.patch  | 12 ++++++++++++
 1 file changed, 12 insertions(+)
 create mode 100644 package/network/services/ppp/patches/610-pppd_compile_fix.patch

diff --git a/package/network/services/ppp/patches/610-pppd_compile_fix.patch b/package/network/services/ppp/patches/610-pppd_compile_fix.patch
new file mode 100644
index 0000000000..474f11832a
--- /dev/null
+++ b/package/network/services/ppp/patches/610-pppd_compile_fix.patch
@@ -0,0 +1,12 @@
+--- a/pppd/Makefile.linux
++++ b/pppd/Makefile.linux
+@@ -48,7 +48,8 @@ MPPE=y
+ # Uncomment the next line to include support for PPP packet filtering.
+ # This requires that the libpcap library and headers be installed
+ # and that the kernel driver support PPP packet filtering.
+-#FILTER=y
++# libpcap statically linked in OpenWRT, hence disabled here.
++FILTER=
+ 
+ # Support for precompiled filters
+ PRECOMPILED_FILTER=y
-- 
cgit v1.2.3