From e7c5412ff0275f29e94609c1faaa513b36b4573b Mon Sep 17 00:00:00 2001
From: Hamish Guthrie <hcg@openwrt.org>
Date: Thu, 10 Mar 2011 10:37:02 +0000
Subject: Add new profile for vpp platform

SVN-Revision: 25997
---
 target/linux/omap35xx/gumstix/defconfig.vpp        | 30 ++++++++++++++++++++++
 target/linux/omap35xx/gumstix/profiles/000-hegw.mk | 29 +++++++++++++++++++++
 target/linux/omap35xx/gumstix/profiles/001-vpp.mk  | 29 +++++++++++++++++++++
 target/linux/omap35xx/gumstix/profiles/gumstix.mk  | 29 ---------------------
 4 files changed, 88 insertions(+), 29 deletions(-)
 create mode 100644 target/linux/omap35xx/gumstix/defconfig.vpp
 create mode 100644 target/linux/omap35xx/gumstix/profiles/000-hegw.mk
 create mode 100644 target/linux/omap35xx/gumstix/profiles/001-vpp.mk
 delete mode 100644 target/linux/omap35xx/gumstix/profiles/gumstix.mk

diff --git a/target/linux/omap35xx/gumstix/defconfig.vpp b/target/linux/omap35xx/gumstix/defconfig.vpp
new file mode 100644
index 0000000000..3924823ccf
--- /dev/null
+++ b/target/linux/omap35xx/gumstix/defconfig.vpp
@@ -0,0 +1,30 @@
+# defconfig for vpp
+
+CONFIG_TARGET_omap35xx=y
+CONFIG_TARGET_omap35xx_gumstix=y
+CONFIG_TARGET_omap35xx_gumstix_Vpp=y
+CONFIG_DEVEL=y
+CONFIG_BROKEN=y
+CONFIG_TOOLCHAINOPTS=y
+CONFIG_GCC_VERSION_4_4_3=y
+CONFIG_INSTALL_LIBSTDCPP=y
+CONFIG_TARGET_OPTIONS=y
+CONFIG_TARGET_OPTIMIZATION="-O2 -pipe -march=armv7-a -mtune=cortex-a8 -funit-at-a-time"
+CONFIG_USE_EGLIBC=y
+CONFIG_EGLIBC_VERSION_2_12=y
+CONFIG_EGLIBC_REVISION="10454"
+CONFIG_EGLIBC_VERSION="2.12"
+CONFIG_LIBC="eglibc"
+CONFIG_LIBC_VERSION="2.12"
+CONFIG_TARGET_SUFFIX="gnueabi"
+CONFIG_TARGET_ROOTFS_PARTSIZE=200
+CONFIG_SOFT_FLOAT=n
+CONFIG_TARGET_ROOTFS_EXT4FS=y
+CONFIG_UDEV_EXTRA_firmware=y
+CONFIG_IMAGEOPT=y
+CONFIG_UCI_PRECONFIG_network_lan_proto="dhcp"
+CONFIG_UCI_PRECONFIG_network_lan_netmask=""
+CONFIG_UCI_PRECONFIG_network_lan_ipaddr=""
+CONFIG_BUSYBOX_CONFIG_STTY=y
+CONFIG_BUSYBOX_CONFIG_TTY=y
+CONFIG_TARGET_omap35xx_vpp=y
diff --git a/target/linux/omap35xx/gumstix/profiles/000-hegw.mk b/target/linux/omap35xx/gumstix/profiles/000-hegw.mk
new file mode 100644
index 0000000000..9ff7fadab8
--- /dev/null
+++ b/target/linux/omap35xx/gumstix/profiles/000-hegw.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2006 - 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+FEATURES:=ubifs
+
+define Profile/Gumstix
+  NAME:=hegw
+  PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+		-firewall -mtd -hotplug2 -udevtrigger -dropbear \
+		ext4 ubifs usb udev kmod-bluetooth ntpclient wpa-supplicant \
+		wireless-tools wpa-cli \
+		bluez-utils bluez-hcidump usbutils \
+		kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
+		kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
+		kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
+		crda iw kmod-usb-hid \
+		kmod-usb-storage kmod-usb-storage-extras kmod-fs-vfat \
+		uboot-omap35xx-omap3_overo \
+		hegw hegwtest mtd-utils
+endef
+
+define Profile/Gumstix/Description
+        Gumstix www.gumstix.com
+endef
+$(eval $(call Profile,Gumstix))
diff --git a/target/linux/omap35xx/gumstix/profiles/001-vpp.mk b/target/linux/omap35xx/gumstix/profiles/001-vpp.mk
new file mode 100644
index 0000000000..bf7c480ef0
--- /dev/null
+++ b/target/linux/omap35xx/gumstix/profiles/001-vpp.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+FEATURES:=ubifs
+
+define Profile/Vpp
+  NAME:=vpp
+  PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+		-firewall -mtd -hotplug2 -udevtrigger -dropbear \
+		ext4 ubifs usb udev kmod-bluetooth ntpclient wpa-supplicant \
+		wireless-tools wpa-cli \
+		bluez-utils bluez-hcidump usbutils \
+		kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
+		kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
+		kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
+		crda iw kmod-usb-hid \
+		kmod-usb-storage kmod-usb-storage-extras kmod-fs-vfat \
+		uboot-omap35xx-omap3_overo \
+		hegw hegwtest mtd-utils ejre
+endef
+
+define Profile/Vpp/Description
+        Gumstix www.gumstix.com
+endef
+$(eval $(call Profile,Vpp))
diff --git a/target/linux/omap35xx/gumstix/profiles/gumstix.mk b/target/linux/omap35xx/gumstix/profiles/gumstix.mk
deleted file mode 100644
index 0b82ec1a60..0000000000
--- a/target/linux/omap35xx/gumstix/profiles/gumstix.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-#
-# Copyright (C) 2006 - 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-FEATURES:=ubifs
-
-define Profile/Gumstix
-  NAME:=gumstix
-  PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
-		-firewall -mtd -hotplug2 -udevtrigger -dropbear \
-		ext4 ubifs usb udev kmod-bluetooth ntpclient wpa-supplicant \
-		wireless-tools wpa-cli \
-		bluez-utils bluez-hcidump usbutils \
-		kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
-		kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
-		kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
-		crda iw kmod-usb-hid \
-		kmod-usb-storage kmod-usb-storage-extras kmod-fs-vfat \
-		uboot-omap35xx-omap3_overo \
-		hegw hegwtest mtd-utils
-endef
-
-define Profile/Gumstix/Description
-        Gumstix www.gumstix.com
-endef
-$(eval $(call Profile,Gumstix))
-- 
cgit v1.2.3