From 2127accd441b1c979c8f3f56f3ad5264542e185a Mon Sep 17 00:00:00 2001
From: Sebastian Kemper <sebastian_ml@gmx.net>
Date: Wed, 18 Nov 2020 22:58:58 +0100
Subject: build: create $(PKG_SYMVERS_DIR) if non-existent

Commit 5d76065 moved the creation of the symvers directory to
include/kernel-build.mk. This is fine when building from scratch. But
when unpacking an SDK the directory doesn't exist and because the kernel
won't be built (again) this directory will not be created by the build
system, causing build failure if make tries to copy files into it.

This moves the creation of the symvers directory back into
include/kernel.mk so that the directory is created in any case.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
---
 include/kernel.mk | 1 +
 1 file changed, 1 insertion(+)

(limited to 'include/kernel.mk')

diff --git a/include/kernel.mk b/include/kernel.mk
index 1ae9c6be29..1466048b0c 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -149,6 +149,7 @@ define collect_module_symvers
 			grep -F $$$$realdir $(PKG_BUILD_DIR)/$$$$subdir/Module.symvers >> $(PKG_BUILD_DIR)/Module.symvers.tmp; \
 	done; \
 	sort -u $(PKG_BUILD_DIR)/Module.symvers.tmp > $(PKG_BUILD_DIR)/Module.symvers; \
+	mkdir -p $(PKG_SYMVERS_DIR); \
 	mv $(PKG_BUILD_DIR)/Module.symvers $(PKG_SYMVERS_DIR)/$(PKG_NAME).symvers
 endef
 
-- 
cgit v1.2.3