From 167846e488603313b5b61d350219e872a24ac471 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 6 Apr 2009 09:56:16 +0000
Subject: add support for config options checking in top-level directory
 stampfiles

SVN-Revision: 15112
---
 include/subdir.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'include')

diff --git a/include/subdir.mk b/include/subdir.mk
index 40e31923bc..d4076e6c47 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -46,9 +46,9 @@ define subdir
   $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name> <target> <depends>
+# Parameters: <subdir> <name> <target> <depends> <config options>
 define stampfile
-  $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
+  $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
   $$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
 	@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
 		$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
-- 
cgit v1.2.3