From f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce Mon Sep 17 00:00:00 2001
From: Yangbo Lu <yangbo.lu@nxp.com>
Date: Tue, 10 Jul 2018 11:58:59 +0800
Subject: layerscape: add armv7 subtarget and ls1021atwr board support

The NXP TWR-LS1021A module is a development system based
on the QorIQ LS1021A processor.
- This feature-rich, high-performance processor module can
  be used standalone or as part of an assembled Tower System
  development platform.
- Incorporating dual Arm Cortex-A7 cores running up to 1 GHz,
  the TWR-LS1021A delivers an outstanding level of performance.
- The TWR-LS1021A offers HDMI, SATA3 and USB3 connectors as
  well as a complete Linux software developer's package.
- The module provides a comprehensive level of security that
  includes support for secure boot, Trust Architecture and
  tamper detection in both standby and active power modes,
  safeguarding the device from manufacture to deployment.

Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
---
 package/boot/uboot-layerscape/Makefile                  | 10 +++++++++-
 package/boot/uboot-layerscape/files/ls1021atwr-uEnv.txt |  8 ++++++++
 2 files changed, 17 insertions(+), 1 deletion(-)
 create mode 100644 package/boot/uboot-layerscape/files/ls1021atwr-uEnv.txt

(limited to 'package/boot')

diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index ffa392cd6e..875e08f0e1 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -59,13 +59,21 @@ define U-Boot/ls2088ardb
   UBOOT_CONFIG:=ls2080ardb
 endef
 
+define U-Boot/ls1021atwr
+  NAME:=NXP LS1021ATWR
+  BUILD_SUBTARGET:=armv7
+  UBOOT_CONFIG:=ls1021atwr_nor
+  ENV_SIZE:=0x20000
+endef
+
 UBOOT_TARGETS := \
   ls1012ardb \
   ls1012afrdm \
   ls1043ardb \
   ls1046ardb \
   ls1088ardb \
-  ls2088ardb
+  ls2088ardb \
+  ls1021atwr
 
 define Build/InstallDev
 	$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
diff --git a/package/boot/uboot-layerscape/files/ls1021atwr-uEnv.txt b/package/boot/uboot-layerscape/files/ls1021atwr-uEnv.txt
new file mode 100644
index 0000000000..f29904e0ad
--- /dev/null
+++ b/package/boot/uboot-layerscape/files/ls1021atwr-uEnv.txt
@@ -0,0 +1,8 @@
+fdtaddr=0x8f000000
+loadaddr=0x81000000
+fdt_high=0xffffffff
+initrd_high=0xffffffff
+nor_boot=cp.b 60f00000 $fdtaddr 100000;cp.b 61000000 $loadaddr 1000000;bootm $loadaddr - $fdtaddr
+bootargs=root=/dev/mtdblock6 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=60000000.nor:1m(rcw),2m(u-boot),1m(u-boot-env),11m(reserved-1),1m(dtb),16m(kernel),32m(rootfs)
+bootcmd=echo starting openwrt ...;run nor_boot
+bootdelay=3
-- 
cgit v1.2.3