From 58b26b60d338e757f3dd88742a3166a80404d8f0 Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Tue, 14 Feb 2012 19:07:07 +0000
Subject: update e2fsprogs

Update e2fsprogs to the last upstream version 1.42.

blkid works fine without 100_add_missing_libpthread_for_blkid.patch.

Signed-off-by: Luka Perkov <openwrt@lukaperkov.net>

SVN-Revision: 30535
---
 package/e2fsprogs/Makefile                         | 16 +++++++---------
 .../e2fsprogs/patches/000-uclibc_compile_fix.patch | 15 +++++++++++++++
 package/e2fsprogs/patches/100-upstream_fix.patch   | 22 ++++++++++++++++++++++
 .../100_add_missing_libpthread_for_blkid.patch     | 11 -----------
 4 files changed, 44 insertions(+), 20 deletions(-)
 create mode 100644 package/e2fsprogs/patches/000-uclibc_compile_fix.patch
 create mode 100644 package/e2fsprogs/patches/100-upstream_fix.patch

(limited to 'package/e2fsprogs')

diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index aac0c5e5be..9e0e9d9c9a 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 # Copyright 2010 Vertical Communications
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.41.12
-PKG_MD5SUM:=1b24a21fc0c2381ef420961cbfec733f
-PKG_RELEASE:=2
+PKG_VERSION:=1.42
+PKG_MD5SUM:=a3c4ffd7352310ab5e9412965d575610
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
@@ -123,12 +123,10 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
-	--enable-shared \
-	--enable-static \
-	--disable-rpath \
 	--enable-elf-shlibs \
-	--enable-dynamic-e2fsck \
-	--disable-tls
+	--disable-tls \
+	--disable-nls \
+	--disable-rpath
 
 define Build/Prepare
 	$(call Build/Prepare/Default)
diff --git a/package/e2fsprogs/patches/000-uclibc_compile_fix.patch b/package/e2fsprogs/patches/000-uclibc_compile_fix.patch
new file mode 100644
index 0000000000..a2e8e428e1
--- /dev/null
+++ b/package/e2fsprogs/patches/000-uclibc_compile_fix.patch
@@ -0,0 +1,15 @@
+Without this patch compiling e2fsprogs 1.42 fails in the case the linux
+kernel headers provide linux/falloc.h but the libc is not implementing
+fallocate() as it is still the case with latest versions of uClibc.
+
+--- a/lib/ext2fs/unix_io.c
++++ b/lib/ext2fs/unix_io.c
+@@ -895,7 +895,7 @@ static errcode_t unix_discard(io_channel
+ 		goto unimplemented;
+ #endif
+ 	} else {
+-#ifdef FALLOC_FL_PUNCH_HOLE
++#if defined HAVE_FALLOCATE && defined FALLOC_FL_PUNCH_HOLE
+ 		/*
+ 		 * If we are not on block device, try to use punch hole
+ 		 * to reclaim free space.
diff --git a/package/e2fsprogs/patches/100-upstream_fix.patch b/package/e2fsprogs/patches/100-upstream_fix.patch
new file mode 100644
index 0000000000..48555a5e46
--- /dev/null
+++ b/package/e2fsprogs/patches/100-upstream_fix.patch
@@ -0,0 +1,22 @@
+--- a/e2fsck/pass1.c
++++ b/e2fsck/pass1.c
+@@ -545,7 +545,7 @@ void e2fsck_pass1(e2fsck_t ctx)
+ 	int	i;
+ 	__u64	max_sizes;
+ 	ext2_filsys fs = ctx->fs;
+-	ext2_ino_t	ino;
++	ext2_ino_t	ino = 0;
+ 	struct ext2_inode *inode;
+ 	ext2_inode_scan	scan;
+ 	char		*block_buf;
+--- a/e2fsck/pass1b.c
++++ b/e2fsck/pass1b.c
+@@ -267,7 +267,7 @@ struct process_block_struct {
+ static void pass1b(e2fsck_t ctx, char *block_buf)
+ {
+ 	ext2_filsys fs = ctx->fs;
+-	ext2_ino_t ino;
++	ext2_ino_t ino = 0;
+ 	struct ext2_inode inode;
+ 	ext2_inode_scan	scan;
+ 	struct process_block_struct pb;
diff --git a/package/e2fsprogs/patches/100_add_missing_libpthread_for_blkid.patch b/package/e2fsprogs/patches/100_add_missing_libpthread_for_blkid.patch
index 9ed9ccab97..e69de29bb2 100644
--- a/package/e2fsprogs/patches/100_add_missing_libpthread_for_blkid.patch
+++ b/package/e2fsprogs/patches/100_add_missing_libpthread_for_blkid.patch
@@ -1,11 +0,0 @@
---- a/lib/blkid/Makefile.in
-+++ b/lib/blkid/Makefile.in
-@@ -126,7 +126,7 @@ tst_types: tst_types.o blkid_types.h
- 
- blkid: ../../misc/blkid.o libblkid.a $(DEPLIBUUID)
- 	$(E) "	LD $@"
--	$(Q) $(CC) -o blkid ../../misc/blkid.o libblkid.a $(LIBUUID)
-+	$(Q) $(CC) -lpthread -o blkid ../../misc/blkid.o libblkid.a $(LIBUUID)
- 
- test_probe: test_probe.in Makefile
- 	$(E) "Creating test_probe..."
-- 
cgit v1.2.3