From 219313833a7249112d9d604afc703e2ef7a6daac Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Wed, 3 Apr 2013 10:00:44 +0000
Subject: Add INA2XX current sensor module.

This is a I2C current/voltage/power sensor.

Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de>

SVN-Revision: 36182
---
 package/kernel/modules/hwmon.mk | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

(limited to 'package/kernel/modules')

diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index bc1f65281d..969e8fa3aa 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -60,6 +60,21 @@ endef
 $(eval $(call KernelPackage,hwmon-adt7475))
 
 
+define KernelPackage/hwmon-ina2xx
+  TITLE:=INA2XX monitoring support
+  KCONFIG:=CONFIG_SENSORS_INA2XX
+  FILES:=$(LINUX_DIR)/drivers/hwmon/ina2xx.ko
+  AUTOLOAD:=$(call AutoLoad,60,ina2xx)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ina2xx/description
+ Kernel module for ina2xx dc current monitor chips
+endef
+
+$(eval $(call KernelPackage,hwmon-ina2xx))
+
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63
-- 
cgit v1.2.3