From 4c9d2c04bae3042007b1314785c0e35049e067d6 Mon Sep 17 00:00:00 2001
From: Hans Dedecker <dedeckeh@gmail.com>
Date: Fri, 23 Dec 2016 16:29:34 +0100
Subject: gre: Remove ttl default value assignment (FS#312)

Don't assign a default ttl of 64 for gre tunnels as
netifd takes care of the default ttl assignment

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
---
 package/network/config/gre/Makefile     | 2 +-
 package/network/config/gre/files/gre.sh | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

(limited to 'package/network/config/gre')

diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index 4511620941..a6b4cac559 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/gre/files/gre.sh b/package/network/config/gre/files/gre.sh
index 3f472c4473..58db1d1381 100755
--- a/package/network/config/gre/files/gre.sh
+++ b/package/network/config/gre/files/gre.sh
@@ -25,7 +25,7 @@ gre_generic_setup() {
 	json_add_string mode "$mode"
 	json_add_int mtu "${mtu:-1280}"
 	[ -n "$df" ] && json_add_boolean df "$df"
-	json_add_int ttl "${ttl:-64}"
+	[ -n "ttl" ] && json_add_int ttl "$ttl"
 	[ -n "$tos" ] && json_add_string tos "$tos"
 	json_add_boolean multicast "$multicast"
 	json_add_string local "$local"
-- 
cgit v1.2.3