From 236e79abb72e22c6e87110a7b0e5288cf3b48efa Mon Sep 17 00:00:00 2001
From: Daniel Golle <daniel@makrotopia.org>
Date: Mon, 21 Sep 2020 18:51:37 +0100
Subject: policycoreutils: fix ALTERNATIVES install location

Fixes: 7817c831ef ("policycoreutils: break into smaller packages")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 package/utils/policycoreutils/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'package/utils/policycoreutils')

diff --git a/package/utils/policycoreutils/Makefile b/package/utils/policycoreutils/Makefile
index 3fd0e39081..03b3fd4879 100644
--- a/package/utils/policycoreutils/Makefile
+++ b/package/utils/policycoreutils/Makefile
@@ -135,7 +135,7 @@ endef
 define BuildUtil
   define Package/$(1)/install
 	$(INSTALL_DIR) $$(1)$(2)
-	$(INSTALL_BIN) $$(PKG_INSTALL_DIR)$(2)/$(3) $$(1)$(2)
+	$(INSTALL_BIN) $$(PKG_INSTALL_DIR)$(2)/$(3) $$(1)$(2)/$(if $(ALTS_$(3)),policycoreutils-$(3),$(3))
   endef
 
   $$(eval $$(call BuildPackage,$(1)))
-- 
cgit v1.2.3