From c5a65a03735d00b756ad580d4ef829716295ff6a Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Wed, 23 Feb 2011 22:59:57 +0000
Subject: Send ipkg-make-index.sh output to stdout

The "Generating index for package" created by ipkg-make-index only
clutter stderr and serve to push previous warnings/errors off-screen.
Instead, send to stdout.

Note:  This would send incorrect invocation messages to stdout as well.
If this is a concern, perhaps we could send them to FD 3, then send 3 to
2...

Signed-off-by: Kevin Locke <klocke@digitalenginesoftware.com>

SVN-Revision: 25678
---
 package/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'package')

diff --git a/package/Makefile b/package/Makefile
index 8e8c6c9a63..2180df3b37 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -89,7 +89,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
 	$(call mklibs)
 
 $(curdir)/index: FORCE
-	@(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+	@(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
 		gzip -9c Packages > Packages.gz \
 	)
 
-- 
cgit v1.2.3